Bug 98268 - Rendering differences in Gitk between Intel and Modesetting driver.
Summary: Rendering differences in Gitk between Intel and Modesetting driver.
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-14 22:43 UTC by Octavio Alvarez
Modified: 2019-09-25 18:58 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Image shouwing rendering differences (40.00 KB, image/png)
2016-10-14 22:43 UTC, Octavio Alvarez
Details
Xorg.0.log for modeset. (25.72 KB, text/plain)
2016-10-16 06:53 UTC, Octavio Alvarez
Details
Xorg.0.log for Intel (44.26 KB, text/x-log)
2016-10-16 06:53 UTC, Octavio Alvarez
Details
intel-force.conf (65 bytes, text/plain)
2016-10-16 06:54 UTC, Octavio Alvarez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Octavio Alvarez 2016-10-14 22:43:20 UTC
Created attachment 127313 [details]
Image shouwing rendering differences

I am attaching a Gitk screen rendered with two different drivers. The Intel driver looks good while the Modesetting driver does not.

[lspci -nv info]
00:02.0 0300: 8086:0046 (rev 02) (prog-if 00 [VGA controller])
	Subsystem: 144d:c06a
	Flags: bus master, fast devsel, latency 0, IRQ 26
	Memory at fc000000 (64-bit, non-prefetchable) [size=4M]
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 1800 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 2
	Capabilities: [a4] PCI Advanced Features
	Kernel driver in use: i915
	Kernel modules: i915

[dmidecode info]
Handle 0x0001, DMI type 1, 27 bytes
System Information
        Manufacturer: SAMSUNG ELECTRONICS CO., LTD.
        Product Name: R530/R730/R540              
        Version: Not Applicable
        Wake-up Type: Power Switch
        SKU Number: Not Specified
        Family: Not Specified

Handle 0x0002, DMI type 2, 17 bytes
Base Board Information
        Manufacturer: SAMSUNG ELECTRONICS CO., LTD.
        Product Name: R530/R730/R540              
        Version: Not Applicable
        Serial Number: .........
        Asset Tag: Tag .....
        Features:
                Board is a hosting board
                Board is replaceable
        Location In Chassis: Not Applicable
        Chassis Handle: 0x0003
        Type: Motherboard
        Contained Object Handles: 1
                0x0000
Comment 1 Michel Dänzer 2016-10-16 02:21:02 UTC
Please attach the Xorg log file corresponding to the problem.
Comment 2 Octavio Alvarez 2016-10-16 06:53:29 UTC
Created attachment 127327 [details]
Xorg.0.log for modeset.
Comment 3 Octavio Alvarez 2016-10-16 06:53:48 UTC
Created attachment 127328 [details]
Xorg.0.log for Intel
Comment 4 Octavio Alvarez 2016-10-16 06:54:57 UTC
Created attachment 127329 [details]
intel-force.conf

This is the configuration file I'm using to force intel loading.
Comment 5 Octavio Alvarez 2016-10-16 07:02:31 UTC
I don't know if this bug is the right place to add the following information: there is another rendering difference described in LibreOffice issue # 99705 [1], where the Calc active cell is not rendered when using the modeset driver + OpenGL disabled but it is shown when using the intel driver (or modeset + OpenGL enabled but this broke rendering horribly). Other people confirmed the issue. Some behavior is described there.

[1] https://bugs.documentfoundation.org/show_bug.cgi?id=99705
Comment 6 Michel Dänzer 2016-10-17 01:50:15 UTC
It sounds like at least some of the issues you're seeing are due to the Mesa driver.
Comment 7 GitLab Migration User 2019-09-25 18:58:39 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1544.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.