Bug 98307 - "st/glsl_to_tgsi: explicitly track all input and output declaration" broke flightgear colors on rs780
Summary: "st/glsl_to_tgsi: explicitly track all input and output declaration" broke fl...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-18 12:26 UTC by Marc Dietrich
Modified: 2017-04-28 09:03 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
screenshot of broken colors (162.19 KB, image/png)
2016-10-18 12:26 UTC, Marc Dietrich
Details
wild guess (4.48 KB, patch)
2016-10-18 15:37 UTC, Nicolai Hähnle
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Dietrich 2016-10-18 12:26:42 UTC
Created attachment 127376 [details]
screenshot of broken colors

Mesa commit 777dcf81b.
Comment 1 Marc Dietrich 2016-10-18 12:41:40 UTC
uHeaven and Valley also broken
Comment 2 Nicolai Hähnle 2016-10-18 15:37:51 UTC
Created attachment 127378 [details] [review]
wild guess

I cannot reproduce this on either llvmpipe or Redwood, and I don't have a pre-Evergreen card anymore.

My best guess is that the driver gets confused because the order of input and output declarations is changed. Does the attached patch help?

If that doesn't help, could you please attach logs with R600_DEBUG=vs,ps both before and after the bad commit?
Comment 3 Marc Dietrich 2016-10-18 15:59:04 UTC
wild is great! Patch fixed the issue in Flightier, Heaven, and Valley. Thanks!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.