Bug 98316 - [SKL] dEQP-EGL.functional.multithread.pbuffer_single_window never completes
Summary: [SKL] dEQP-EGL.functional.multithread.pbuffer_single_window never completes
Status: RESOLVED DUPLICATE of bug 98331
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Tapani Pälli
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 98315
  Show dependency treegraph
 
Reported: 2016-10-19 01:19 UTC by Mark Janes
Modified: 2016-12-14 01:49 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
output running test on HSW (2.45 KB, text/plain)
2016-10-20 08:15 UTC, Tapani Pälli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2016-10-19 01:19:56 UTC
This test spins forever on sklgt2.

I built the nougat-cts-dev branch of deqp, plus a fix from Ken:
https://github.com/janesma/deqp/tree/nougat-cts-dev

To enable egl testing, I passed -DDEQP_TARGET=x11_egl to the deqp build.
Comment 1 Tapani Pälli 2016-10-20 08:15:51 UTC
Created attachment 127418 [details]
output running test on HSW

there seems to be some X related issues at least, I managed to get 3 different X errors when running this:

1. XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
2. X Error of failed request:  BadIDChoice (invalid resource ID chosen for this connection)
3. deqp-egl: xcb_conn.c:195: write_vec: Assertion `!c->out.queue_len' failed.

wow ..
Comment 2 Mark Janes 2016-12-09 21:27:47 UTC
This test now completes, but intermittently crashes.

It continues to be disabled in the CI.  I am entering this comment because Tapani requested I re-evaluate intermittent EGL failures.
Comment 3 Mark Janes 2016-12-09 22:17:03 UTC
Correction: after enabling the test, I found that it occasionally hangs forever.
Comment 4 Tapani Pälli 2016-12-12 10:41:57 UTC
please test with hack/fix attached to bug #98331 .. for me this test passes nicely with that.
Comment 5 Mark Janes 2016-12-14 01:49:52 UTC

*** This bug has been marked as a duplicate of bug 98331 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.