Bug 98328 - [dEQP, EGL] luminance tests fail
Summary: [dEQP, EGL] luminance tests fail
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Tapani Pälli
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 98342 (view as bug list)
Depends on:
Blocks: 98315
  Show dependency treegraph
 
Reported: 2016-10-19 17:57 UTC by Mark Janes
Modified: 2016-10-25 04:59 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
fix (1.26 KB, patch)
2016-10-20 08:06 UTC, Tapani Pälli
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2016-10-19 17:57:11 UTC
Several luminance tests fail with this signature:

dEQP-EGL.functional.image.api.create_image_gles2_tex2d_luminance

Got EGL_BAD_PARAMETER: eglCreateImageKHR() at teglImageUtil.cpp:173
Comment 1 Tapani Pälli 2016-10-20 06:48:46 UTC
*** Bug 98342 has been marked as a duplicate of this bug. ***
Comment 2 Tapani Pälli 2016-10-20 08:05:53 UTC
patch on its way to CI testing ..
Comment 3 Tapani Pälli 2016-10-20 08:06:23 UTC
Created attachment 127416 [details] [review]
fix
Comment 4 Tapani Pälli 2016-10-25 04:59:17 UTC
commit 58b4fef8bb7b959ac0918d08a76c92c4c86cb262
Author: Tapani Pälli <tapani.palli@intel.com>
Date:   Thu Oct 20 11:03:26 2016 +0300

    mesa: add missing formats to driGLFormatToImageFormat
    
    Fixes following dEQP tests:
    
       dEQP-EGL.functional.image.api.create_image_gles2_tex2d_luminance
       dEQP-EGL.functional.image.api.create_image_gles2_tex2d_luminance_alpha
    
    Signed-off-by: Tapani Pälli <tapani.palli@intel.com>
    Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=98328


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.