Bug 98329 - [dEQP, EGL, SKL, BDW, BSW] dEQP-EGL.functional.image.render_multiple_contexts.gles2_renderbuffer_depth16_depth_buffer
Summary: [dEQP, EGL, SKL, BDW, BSW] dEQP-EGL.functional.image.render_multiple_contexts...
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Chad Versace
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 98344 (view as bug list)
Depends on:
Blocks: 98315
  Show dependency treegraph
 
Reported: 2016-10-19 17:59 UTC by Mark Janes
Modified: 2016-12-12 17:44 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2016-10-19 17:59:00 UTC
fails with:

Creating gles2 context with config id: 3 context: 0
Creating gles2 context with config id: 3 context: 1
Rendering with depth buffer
Modifying EGLImage with glClear to renderbuffer
Rendering with depth buffer
Image comparison failed: max difference = (128, 136, 128, 0), threshold = (32, 32, 32, 32)
Comment 1 Tapani Pälli 2016-10-25 09:22:33 UTC
*** Bug 98344 has been marked as a duplicate of this bug. ***
Comment 2 Tapani Pälli 2016-10-25 09:23:22 UTC
Mark, does this fail you on anything else than Skylake? For me it reliably fails on SKL but passes nicely on HSW.
Comment 3 Mark Janes 2016-10-25 18:57:46 UTC
It fails on SKL, BDW, and BSW.

Apologies: I should have put that in the bug when I wrote it.
Comment 4 Chad Versace 2016-12-09 23:46:11 UTC
Tapani, are you still working on this? I confirmed that it still fails on Mesa master@d0d21532f with DEQP_TARGET=x11_egl.
Comment 6 Tapani Pälli 2016-12-12 08:01:36 UTC
I've verified that this fixes it for me -> resolving as fixed.

--- 8< ---
commit 42011be1e27f59d750b781c10766e19ec0ee6ff5
Author: Chad Versace <chadversary@chromium.org>
Date:   Fri Dec 9 16:22:52 2016 -0800

    i965/mt: Disable HiZ when sharing depth buffer externally (v2)
    
    intel_miptree_make_shareable() discarded and disabled CCS. Fix it so
    that it discards and disables HiZ too.
    
    Fixes dEQP-EGL.functional.image.render_multiple_contexts.gles2_renderbuffer_depth16_depth_buffer
    on Skylake.
    
    v2: Actually do what the commit message says. Discard the HiZ buffer.
    
    Fixes: https://bugs.freedesktop.org/show_bug.cgi?id=98329
    Reviewed-by: Topi Pohjolainen <topi.pohjolainen@intel.com>
    Reviewed-by: Kenneth Graunke <kenneth@whitecape.org>
    Cc: Nanley Chery <nanley.g.chery@intel.com
    Cc: Haixia Shi <hshi@chromium.org>
    Cc: mesa-stable@lists.freedesktop.org


bug/show.html.tmpl processed on Feb 24, 2017 at 03:43:04.
(provided by the Example extension).