Bug 98418 - GPU HANG: ecode 9:0:0x84d ffff8, in Xorg [1146], reason: Hang on render ring, action: reset
Summary: GPU HANG: ecode 9:0:0x84d ffff8, in Xorg [1146], reason: Hang on render ring,...
Status: CLOSED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 12.0
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Martin Sillence
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-24 20:17 UTC by Martin Sillence
Modified: 2017-01-10 08:59 UTC (History)
2 users (show)

See Also:
i915 platform: SKL
i915 features: GPU hang


Attachments
/sys/class/drm/card0/error (27.21 KB, application/gzip)
2016-10-25 07:12 UTC, Martin Sillence
Details
GPU crash dump (125.06 KB, text/plain)
2016-11-03 15:58 UTC, Matej Usaj
Details
GPU crash dump, mesa-13.0.0 (126.75 KB, text/plain)
2016-11-06 23:33 UTC, Matej Usaj
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Sillence 2016-10-24 20:17:26 UTC
Hi,

I'm getting GPU hangs after some updates
kernel 4.8.3 
Hardware dell xps 13 skylake: Dell Iris Graphics 540

[drm] GPU HANG: ecode 9:0:0x84dffff8, in Xorg [1146], reason: Hang on render ring, action: reset
[drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Comment 1 Jari Tahvanainen 2016-10-25 07:04:17 UTC
Martin - please attach gpu crash dump
$ cat /sys/class/drm/card0/error | bz2 > error.bz2
Comment 2 Martin Sillence 2016-10-25 07:12:55 UTC
Created attachment 127529 [details]
/sys/class/drm/card0/error

Sorry I thought I'd attached this when I created the issue.
Comment 3 Matej Usaj 2016-11-03 15:57:04 UTC
I have the same error:

-- chipset: Skylake-H
-- system architecture: 64-bit
-- xf86-video-intel: 2.99.917_p20161024
-- xserver: 1.18.4
-- mesa: 12.0.1
-- libdrm: 2.4.70
-- kernel: 4.8.6-gentoo
-- Linux distribution: Gentoo
-- Machine or mobo model: Alienware 15 R2
Comment 4 Matej Usaj 2016-11-03 15:58:40 UTC
Created attachment 127720 [details]
GPU crash dump
Comment 5 Matej Usaj 2016-11-03 16:01:13 UTC
I forgot to add that I can reproduce this bug every time by launching Eclipse IDE.
Comment 6 yann 2016-11-03 16:59:40 UTC
Assigning to Mesa product.

Kernel: 4.8.3
Platform: Skylake-H (pci id: 0x1926, pci revision: 0x0a, pci subsystem: 1028:0704)
Mesa: 12.0.1

From this error dump, hung is happening in render ring batch with active head at 0xfb9f2130, with 0x7b000005 (3DPRIMITIVE) as IPEHR.

We can note also ERROR: 0x00000001 and in the render ring "Invalid PTE Fault".

Batch extract (around 0xfb9f2130):

0xfb9f2110:      0x78090005: 3DSTATE_VERTEX_ELEMENTS
0xfb9f2114:      0x02000000:    buffer 0: invalid, type 0x0000, src offset 0x0000 bytes
0xfb9f2118:      0x22220000:    (0.0, 0.0, 0.0, 0.0), dst offset 0x00 bytes
0xfb9f211c:      0x02f60000:    buffer 0: invalid, type 0x00f6, src offset 0x0000 bytes
0xfb9f2120:      0x11230000:    (X, Y, 0.0, 1.0), dst offset 0x00 bytes
0xfb9f2124:      0x02f60004:    buffer 0: invalid, type 0x00f6, src offset 0x0004 bytes
0xfb9f2128:      0x11230000:    (X, Y, 0.0, 1.0), dst offset 0x00 bytes
Bad length 7 in (null), expected 6-6
0xfb9f212c:      0x7b000005: 3DPRIMITIVE: fail sequential
0xfb9f2130:      0x00000000:    vertex count
0xfb9f2134:      0x00000063:    start vertex
0xfb9f2138:      0x0000101c:    instance count
0xfb9f213c:      0x00000001:    start instance
0xfb9f2140:      0x00000000:    index bias
0xfb9f2144:      0x00000000: MI_NOOP
Comment 7 yann 2016-11-03 17:00:33 UTC
Please try to update your Mesa to latest one and see if this issue still occurs.
Comment 8 Matej Usaj 2016-11-06 23:32:56 UTC
Mesa updated to 13.0.0:
    Device: Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2)  (0x191b)
    Version: 13.0.0

The problem persists. Attaching the new gpu dump using updated mesa.
Comment 9 Matej Usaj 2016-11-06 23:33:55 UTC
Created attachment 127806 [details]
GPU crash dump, mesa-13.0.0
Comment 10 Mark Janes 2016-12-07 17:54:57 UTC
 Martin, please verify that you can reproduce this after switching X to use modesetting instead of xf86-video-intel:

https://bbs.archlinux.org/viewtopic.php?id=211792
Comment 11 Martin Sillence 2016-12-09 06:24:35 UTC
I'm not seeing this any more.
I've done a few updates since.

Might be worth checking with  Matej/Yann.

Thanks,
M

> https://bugs.freedesktop.org/show_bug.cgi?id=98418
>
> Mark Janes <mark.a.janes@intel.com> changed:
>
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>            Assignee|intel-3d-bugs@lists.freedes |martin@luminoussheep.net
>                    |ktop.org                    |
>              Status|REOPENED                    |NEEDINFO
>
> --- Comment #10 from Mark Janes <mark.a.janes@intel.com> ---
>  Martin, please verify that you can reproduce this after switching X to
> use
> modesetting instead of xf86-video-intel:
>
> https://bbs.archlinux.org/viewtopic.php?id=211792
>
> --
> You are receiving this mail because:
> You reported the bug.
> You are the assignee for the bug.
Comment 12 Matej Usaj 2017-01-10 02:46:17 UTC
I've updated the following packages:
mesa-13.0.3
xf86-video-intel-2.99.917_p20161206
libdrm-2.4.74
and
kernel-4.9.2

Everything seems to be working fine now.

Thanks,
M
Comment 13 yann 2017-01-10 08:59:05 UTC
(In reply to Matej Usaj from comment #12)
> I've updated the following packages:
> mesa-13.0.3
> xf86-video-intel-2.99.917_p20161206
> libdrm-2.4.74
> and
> kernel-4.9.2
> 
> Everything seems to be working fine now.
> 
> Thanks,
> M

thanks Matej


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.