Bug 98421 - src/loader/loader.c:111:40: error: unknown type name ‘drmDevicePtr’
Summary: src/loader/loader.c:111:40: error: unknown type name ‘drmDevicePtr’
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2016-10-24 22:46 UTC by Vinson Lee
Modified: 2016-10-26 00:23 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2016-10-24 22:46:55 UTC
mesa: 41034abfe63012784c9e9e36856d878928cecd99 (master 13.1.0-devel)

$ scons
[...]
  Compiling src/loader/loader.c ...
src/loader/loader.c:111:40: error: unknown type name ‘drmDevicePtr’
 static char *drm_construct_id_path_tag(drmDevicePtr device)
                                        ^

scons: building terminated because of errors.
4a183f4d06f800f44e8a679dc2ae60149105e1ce is the first bad commit
commit 4a183f4d06f800f44e8a679dc2ae60149105e1ce
Author: Emil Velikov <emil.velikov@collabora.com>
Date:   Wed Sep 7 19:03:29 2016 +0100

    scons: loader: use libdrm when available

    Signed-off-by: Emil Velikov <emil.velikov@collabora.com>
    Reviewed-by: Axel Davy <axel.davy@ens.fr>
    Reviewed-by: Nicolai Hähnle <nicolai.haehnle@amd.com>

:040000 040000 00962395c62ef5998909b9085844f2cc4f3765ae 32167484a10b914d0a3c486ab8b9ee0a2518080b M	src
bisect run success
Comment 1 Vinson Lee 2016-10-26 00:23:48 UTC
commit f2770fb3d5e7a4a456f8f14726f72a1e37496419
Author: Vinson Lee <vlee@freedesktop.org>
Date:   Mon Oct 24 16:33:01 2016 -0700

    scons: Require libdrm >= 2.4.66 for DRM.
    
    configure.ac already requires 2.4.66.
    
    Fix SCons build. drmDevicePtr is not available until libdrm 2.4.65.
    
      Compiling src/loader/loader.c ...
    src/loader/loader.c:111:40: error: unknown type name ‘drmDevicePtr’
     static char *drm_construct_id_path_tag(drmDevicePtr device)
                                            ^
    
    Fixes: 4a183f4d06f8 ("scons: loader: use libdrm when available")
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=98421
    Signed-off-by: Vinson Lee <vlee@freedesktop.org>
    Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
    Reviewed-by: Vedran Miletić <vedran@miletic.net>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.