Bug 98584 - [SNB] Mesa 13.0.0 causes segfault when launching ZSNES 1.51
Summary: [SNB] Mesa 13.0.0 causes segfault when launching ZSNES 1.51
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 13.0
Hardware: x86-64 (AMD64) Linux (All)
: low minor
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-11-03 23:24 UTC by Marcus Hoffren
Modified: 2019-07-04 08:21 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
strace verbose log (205.75 KB, text/plain)
2016-11-03 23:24 UTC, Marcus Hoffren
Details
Xorg log (17.69 KB, text/plain)
2016-11-04 22:47 UTC, Marcus Hoffren
Details
gdb backtrace (3.22 KB, text/plain)
2016-11-04 22:47 UTC, Marcus Hoffren
Details
libdrm version and use flags (978 bytes, text/plain)
2016-11-04 22:49 UTC, Marcus Hoffren
Details
intel video driver version and use flags (984 bytes, text/plain)
2016-11-04 22:51 UTC, Marcus Hoffren
Details
uname -a (131 bytes, text/plain)
2016-11-04 22:52 UTC, Marcus Hoffren
Details
lspci (993 bytes, text/plain)
2016-11-04 22:53 UTC, Marcus Hoffren
Details
gdb backtrace with mesa (4.30 KB, text/plain)
2016-11-04 23:30 UTC, Marcus Hoffren
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Hoffren 2016-11-03 23:24:00 UTC
Created attachment 127744 [details]
strace verbose log

Present since mesa-13.0.0-rc1

Steps to recreate:

Launch zsnes in fullscreen mode.

Launching in windowed mode, and then switching to fullscreen works as expected.

Effect:

Segfault (see attached strace log)
Comment 1 Mark Janes 2016-11-04 18:30:57 UTC
This works for me on debian stretch.  Can you provide more information about your system?

Hardware / GPU
Distribution
libdrm version
xorg config
Comment 2 Matt Turner 2016-11-04 19:58:29 UTC
A backtrace would be nice. The strace isn't very useful.
Comment 3 Marcus Hoffren 2016-11-04 22:46:52 UTC
Sure. Let me attach some system/build information and backtrace.
Comment 4 Marcus Hoffren 2016-11-04 22:47:13 UTC
Created attachment 127769 [details]
Xorg log
Comment 5 Marcus Hoffren 2016-11-04 22:47:34 UTC
Created attachment 127770 [details]
gdb backtrace
Comment 6 Marcus Hoffren 2016-11-04 22:49:42 UTC
Created attachment 127771 [details]
libdrm version and use flags
Comment 7 Marcus Hoffren 2016-11-04 22:51:31 UTC
Created attachment 127772 [details]
intel video driver version and use flags
Comment 8 Marcus Hoffren 2016-11-04 22:52:11 UTC
Created attachment 127773 [details]
uname -a
Comment 9 Marcus Hoffren 2016-11-04 22:53:20 UTC
Created attachment 127774 [details]
lspci
Comment 10 Matt Turner 2016-11-04 22:54:26 UTC
(In reply to Marcus Hoffren from comment #5)
> Created attachment 127770 [details]
> gdb backtrace

Could you recompile Mesa with debugging symbols? The backtrace won't contain much information without it. Try this:

mattst88@macbook ~ % cat /etc/portage/env/splitdebug.conf 
CFLAGS="$CFLAGS -ggdb3"
CXXFLAGS="$CFLAGS"
FEATURES="splitdebug"
mattst88@macbook ~ % cat /etc/portage/package.env/splitdebug 
media-libs splitdebug.conf

and just recompile.
Comment 11 Matt Turner 2016-11-04 22:54:58 UTC
(In reply to Matt Turner from comment #10)
> (In reply to Marcus Hoffren from comment #5)
> > Created attachment 127770 [details]
> > gdb backtrace
> 
> Could you recompile Mesa with debugging symbols? The backtrace won't contain
> much information without it. Try this:
> 
> mattst88@macbook ~ % cat /etc/portage/env/splitdebug.conf 
> CFLAGS="$CFLAGS -ggdb3"
> CXXFLAGS="$CFLAGS"
> FEATURES="splitdebug"
> mattst88@macbook ~ % cat /etc/portage/package.env/splitdebug 
> media-libs splitdebug.conf

Oops, this is supposed to be

media-libs/mesa splitdebug.conf

of course.
Comment 12 Marcus Hoffren 2016-11-04 22:59:08 UTC
(In reply to Matt Turner from comment #11)
> (In reply to Matt Turner from comment #10)
> > (In reply to Marcus Hoffren from comment #5)
> > > Created attachment 127770 [details]
> > > gdb backtrace
> > 
> > Could you recompile Mesa with debugging symbols? The backtrace won't contain
> > much information without it. Try this:
> > 
> > mattst88@macbook ~ % cat /etc/portage/env/splitdebug.conf 
> > CFLAGS="$CFLAGS -ggdb3"
> > CXXFLAGS="$CFLAGS"
> > FEATURES="splitdebug"
> > mattst88@macbook ~ % cat /etc/portage/package.env/splitdebug 
> > media-libs splitdebug.conf
> 
> Oops, this is supposed to be
> 
> media-libs/mesa splitdebug.conf
> 
> of course.

Ok. Recompiling and creating new backtrace.
Comment 13 Marcus Hoffren 2016-11-04 23:30:12 UTC
Created attachment 127776 [details]
gdb backtrace with mesa
Comment 14 Matt Turner 2017-03-22 01:57:45 UTC
Sorry for the slow response. The SNB doesn't get turned on very often anymore.

I've got mesa-13.0.3 installed and I cannot reproduce. I switched zsnes to 640x480 ODS full screen. Could you try mesa-13.0.5 (latest stable in Gentoo) or the unstable 13.0.6/17.0.2?
Comment 15 Marcus Hoffren 2017-08-22 18:43:43 UTC
Sorry for late reply. Still present in mesa-17.2.0_rc5, and has been with all versions before down until, and including mesa-13.0.0-rc1.
Comment 16 Tapani Pälli 2017-08-24 09:02:51 UTC
I tried as well but could not reproduce this on my SNB Mobile (0x126), I tried with Mesa master (commit hash 4009370232), mesa-17.2.0_rc5 and mesa-13.0.0-rc1. I launched zsnes in 1024x768 fullscreen mode and this was on Ubuntu 16.04.
Comment 17 Mark Janes 2018-01-10 19:46:20 UTC
setting priority to low, since no one here can reproduce it.
Comment 18 vadym 2018-05-16 09:47:08 UTC
Not able to reproduce this on:

XUbuntu 16.04 / Fedora 
Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
Intel(R) Sandybridge Mobile  (0x126)
mesa 17.2.8
Comment 19 Denis 2019-07-04 08:21:24 UTC
as we tried to reproduce it and couldn't, and there were no any feedback from reporter, closing.
Please fill free to reopen in case if you can reproduce it.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.