Bug 98608 - DisplayPort on Radeon HD 5770 not working for 3440x1440 display
Summary: DisplayPort on Radeon HD 5770 not working for 3440x1440 display
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
Depends on:
Reported: 2016-11-06 10:48 UTC by Robin
Modified: 2019-11-19 07:58 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

Output of: journalctl -b _COMM=gdm-x-session (292.17 KB, text/plain)
2016-11-06 10:48 UTC, Robin
no flags Details
dmesg output (96.13 KB, text/plain)
2016-11-07 20:08 UTC, Robin
no flags Details

Description Robin 2016-11-06 10:48:13 UTC
Created attachment 127797 [details]
Output of: journalctl -b _COMM=gdm-x-session

I recently bought a DisplayPort KVM switch to be able to easily alternate between my laptop and desktop when hooked up to a LG 35UC87C monitor.

I had previously been running this without any problems on Fedora 22 using the HDMI connection to my Radeon HD5770. However, I got only a blank screen when I switched to using the DisplayPort connection.

I decided to update to Fedora 24 before doing anything else and ended up doing this as a fresh install on the root drive after somehow messing up the upgrade (home and data disks are separate).

Currently it works correctly if hooked up to the HDMI cable.
It works correctly with the DisplayPort cable under Windows (ie. this is not a hardware fault)

If attached to the DisplayPort it works if I have nomodeset on the kernel line - but of course only at low resolution.

If I put radeon.modeset=1 on the kernel line it blanks almost immediately after booting starts.

If I add a second monitor to the HDMI cable I can see the Xserver starts and is correctly spreading itself across both monitors, just the LG monitor is blank.

The LG monitor is being correctly detected as shown by the output of xrandr:

Screen 0: minimum 320 x 200, current 5360 x 1440, maximum 8192 x 8192
DisplayPort-0 connected primary 3440x1440+1920+0 (normal left inverted right x axis y axis) 800mm x 335mm
3440x1440 59.97*+ 49.99 29.99
2560x1080 60.00
1920x1080 60.00 59.94
1680x1050 59.95
1600x900 60.00
1280x1024 60.02
1280x800 59.81
1152x864 59.97
1280x720 60.00 59.94
1024x768 60.00
800x600 60.32
720x480 60.00 59.94
640x480 60.00 59.94
HDMI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
1920x1080 60.00*+ 50.00 59.94
1920x1080i 60.00 50.00 59.94
1680x1050 59.88
1280x1024 75.02 60.02
1440x900 59.90
1280x960 60.00
1280x800 59.91
1152x864 75.00
1280x720 60.00 50.00 59.94
1440x576 50.00
1024x768 75.03 70.07 60.00
1440x480 60.00 59.94
832x624 74.55
800x600 72.19 75.00 60.32 56.25
720x576 50.00
720x480 60.00 59.94
640x480 75.00 66.67 60.00 59.94
720x400 70.08
DVI-0 disconnected (normal left inverted right x axis y axis)
DVI-1 disconnected (normal left inverted right x axis y axis)

If I use the "Display Configuration" interface in KDE and lower the resolution to 2560x1080 then it turns on. However I can't find any way of getting it to display at the full resolution of 3440x1440 - it always just blanks and the monitor says it has no signal.

lspci output is:
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Juniper XT [Radeon HD 5770]  

/var/log/Xorg.0.log doesn't seem to be up to date so I've attached the output of
journalctl -b _COMM=gdm-x-session
Comment 1 Alex Deucher 2016-11-07 18:00:46 UTC
Please attach your dmesg output.  Does the displayport connection work if you select a different mode?  E.g., 3440x1440@30Hz or 1080p?
Comment 2 Robin 2016-11-07 20:08:36 UTC
Created attachment 127820 [details]
dmesg output
Comment 3 Robin 2016-11-07 20:13:26 UTC
It works on any other mode that I've tried except for the full resolution mode. eg. 2560x1080 works (as I wrote above, I don't know if you just missed that or if I'm not understanding your question properly?).

The only mode where the monitor doesn't display anything is the full 3440x1440 mode.

The 3440x1440 mode does work through DisplayPort when I attach my laptop (Windows) to it when going through the same KVM switch. It also works with the PC & Radeon card when running Windows. (The presence of the KVM switch makes no difference, it still doesn't work if I hook it up directly).
Comment 4 Robin 2016-11-07 20:16:21 UTC
I also just tried 3440x1440 @ 30Hz (and at 50 Hz & 60Hz) - the frequency makes no difference.
Comment 5 Martin Peres 2019-11-19 07:58:05 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-video-ati/issues/165.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.