Bug 98700 - ssh -X hangs after entering password
Summary: ssh -X hangs after entering password
Alias: None
Product: XQuartz
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: unspecified
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
Depends on:
Reported: 2016-11-13 03:28 UTC by lixpas
Modified: 2018-01-22 18:40 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

installed ports (20.68 KB, text/plain)
2016-11-18 16:31 UTC, Leopold Talirz

Description lixpas 2016-11-13 03:28:11 UTC

On Mac OS X Sierra I have updated XQuartz yesterday to the latest version and now X forwarding in ssh does not work anymore. When logging to a remote server "ssh -X" hangs after entering a password. Before updating XQuartz there was no problem. Also ssh without the -X  flag works normally.

Here's the relevant ssh debug output:
debug1: Next authentication method: password
$USER@$SERVER's password:
debug3: send packet: type 50
debug2: we sent a password packet, wait for reply
debug3: receive packet: type 52
debug1: Authentication succeeded (password).
Authenticated to $SERVER ([$IP]:22).
debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug3: send packet: type 90
debug1: Requesting no-more-sessions@openssh.com
debug3: send packet: type 80
debug1: Entering interactive session.
debug1: pledge: exec
debug3: receive packet: type 91
debug2: callback start
debug2: client_x11_get_proto: /opt/X11/bin/xauth -f /var/folders/n3/h3cc39xn15516xf73xz34500mf0djh/T//ssh-SR79VQ4YXEgI/xauthfile generate /private/tmp/com.apple.launchd.FndqLKOn2c/org.macosforge.xquartz:0 MIT-MAGIC-COOKIE-1 untrusted timeout 1260 2>/dev/null

I have tried reinstalling XQuartz, but it did not help. If you can provide any info, I would be very grateful


Comment 1 Jeremy Huddleston Sequoia 2016-11-13 04:19:35 UTC
Is ssh haning or is something haning on the other end?
Is Sierra with XQuartz the local or remote end of the connection?
Comment 2 lixpas 2016-11-13 07:03:42 UTC
Sorry for incomplete info. Mac OS Sierra + XQuartz is the local side, remote is Suse Linux cluster headnode. SSH is hanging on the local side with the last line of the debug output (as shown in the first comment):
debug2: client_x11_get_proto: /opt/X11/bin/xauth -f /var/folders/n3/h3cc39xn15516xf73xz34500mf0djh/T//ssh-SR79VQ4YXEgI/xauthfile generate /private/tmp/com.apple.launchd.FndqLKOn2c/org.macosforge.xquartz:0 MIT-MAGIC-COOKIE-1 untrusted timeout 1260 2>/dev/null

It seems X11 cannot start, but I don't understand why.
Comment 3 Leopold Talirz 2016-11-18 16:31:06 UTC
Created attachment 128057 [details]
installed ports
Comment 4 Leopold Talirz 2016-11-18 16:33:28 UTC
I have a similar problem with XQuartz 2.7.11 on MacOS 10.10.5 (Yosemite).

While things were running smoothly with XQuartz 2.7.9, after downloading and installing 2.7.11. I noticed that:

 * ssh -X hangs (while ssh works)
 * opening the XQuartz.app application via the file browser shows the icon "jumping" for ~3 minutes (indicating that the application is not responding)
   Afterward the long waiting period, it seems to have opened fine
 * during the installation of the XQuartz package, running of the package scripts took an unusually long time

I then reinstalled XQuartz 2.7.9 from https://www.xquartz.org/releases/XQuartz-2.7.9.html and - the problem was gone.

FYI, I do have macports on my mac, see post above for a list of my installed ports.

Hope it helps,


P.S. Sorry for the double post - I didn't quite get that "posting my attachment" didn't simply add it to my comment.
Comment 5 lixpas 2016-11-19 03:48:00 UTC
Downgrading to XQuartz 2.7.9 worked for me too, 'ssh -X' now forwards the X11 environment correctly.
Comment 6 Hamilton Turner 2018-01-21 19:37:29 UTC
Experienced the same issue with Mac OS 10.10.5 immediately after upgrading to 2.7.11. 

However, as soon as I restarted, the issue was resolved. 

I do recall the XQuartz installer warning me to logout/log-back-in, so perhaps this bug is not so much a bug as expected behavior if the upgrade is not completed by re-logging in.
Comment 7 Jeremy Huddleston Sequoia 2018-01-22 18:40:08 UTC
Sounds like the libxcb was out of date for the original reporter and you just needed to logout to get DISPLAY setup for the more recent report.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.