Bug 98713 - [G965] GPU HANG: ecode 4:0:0x00ba6937, in Xorg [1264], reason: Engine(s) hung, action: reset
Summary: [G965] GPU HANG: ecode 4:0:0x00ba6937, in Xorg [1264], reason: Engine(s) hung...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Björn Persson
QA Contact: Intel 3D Bugs Mailing List
URL: https://bugzilla.redhat.com/show_bug....
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-13 22:52 UTC by Björn Persson
Modified: 2017-02-07 22:36 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
/sys/class/drm/card0/error (83.03 KB, application/x-bzip2)
2016-11-13 22:52 UTC, Björn Persson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Persson 2016-11-13 22:52:31 UTC
Created attachment 127961 [details]
/sys/class/drm/card0/error

The whole GUI sometimes freezes permanently. The display shows no reactions to any events until I reboot the computer. Logging in by SSH I can see that the OS is at least partially working. Network traffic flows and I can read files. When I kill processes most of them terminate, but the images of their windows remain unchanged on the display. Some processes linger as zombies. When I run "reboot" the SSH session ends, and I can't log in again, but the system does not reboot. Only a hardware reset reboots the computer.

I don't have a reliable way of triggering a freeze, but it happens only when something is changing in the GUI, often when I resize a window or open a new window. It has never happened when I wasn't working on the local console. When opening a new window it looks like it's not quite done drawing the window decorations when it freezes.

The following appears in the system log:

Nov 13 20:05:36 hactar kernel: [drm] stuck on render ring
Nov 13 20:05:36 hactar kernel: [drm] GPU HANG: ecode 4:0:0x00ba6937, in Xorg [1264], reason: Engine(s) hung, action: reset
Nov 13 20:05:36 hactar kernel: [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Nov 13 20:05:36 hactar kernel: [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Nov 13 20:05:36 hactar kernel: [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
Nov 13 20:05:36 hactar kernel: [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Nov 13 20:05:36 hactar kernel: [drm] GPU crash dump saved to /sys/class/drm/card0/error

architecture: x86-64
chipset: G35
motherboard: Asus P5E-V HDMI 
display connector: HDMI
distribution: Fedora 23

The permanent GUI freezes happen with Linux 4.6 and 4.7. Today it happened with Fedora's kernel-4.7.9-100.fc23. They do not happen with kernel-4.5.7-202.fc23.

Before Linux 4.6 the GUI would only freeze for a second or so. Then the screen went black for a moment, and then everything worked normally again except that the mouse pointer was invisible. To get the pointer back I had to lock and then unlock the console. This also happened only when something was changing in the GUI, often when I resized a window. Those symptoms began when I upgraded from Fedora 21 to Fedora 23, and continued until the first 4.6 kernel.

Other currently installed packages:

xorg-x11-server-Xorg-1.18.3-3.fc23
xorg-x11-drv-intel-2.99.917-19.20151206.fc23
mesa-dri-drivers-11.1.0-4.20151218.fc23
libdrm-2.4.66-1.fc23
Comment 1 Mark Janes 2016-12-07 17:46:22 UTC
Please verify that you can reproduce this using the modesetting DDX.  A known issue in xf86-video-intel may be causing your hang.

eg: https://bbs.archlinux.org/viewtopic.php?id=211792
Comment 2 Björn Persson 2017-02-05 19:38:58 UTC
I think I eventually figured out what "the modesetting DDX" is. I think it's probably the same thing as "the modesetting Xorg driver" (which if I understand correctly does not perform any modesetting, because kernel drivers do that) that is discussed in this email thread:

https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/AUPYPJMFJZMHPEKN24LBABZKIEOV4NU5/

I think that when I see many "modeset(0)" lines in Xorg.0.log, then the modesetting DDX is in use, whereas when I see many "intel(0)" and also these lines:

[    76.406] (II) UnloadModule: "modesetting"
[    76.406] (II) Unloading modesetting

then xf86-video-intel is in use.

However, I'm now running Fedora 25, and during a few weeks of opening, closing, moving and resizing windows I haven't been able to trigger a GPU hang, neither with the "modesetting" driver nor with the "intel" driver. It seems like the bug may have been fixed, or the probability that a hang will occur may have decreased.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.