Bug 98724 - garbled output using glDrawElementsIndirect
Summary: garbled output using glDrawElementsIndirect
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: Other Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
Depends on:
Reported: 2016-11-14 17:47 UTC by Logan McNaughton
Modified: 2019-09-25 17:55 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

api traces (1.89 MB, application/x-xz)
2016-11-15 01:57 UTC, Aaron Paden
dmesg (50.46 KB, text/plain)
2016-11-17 01:14 UTC, Aaron Paden

Description Logan McNaughton 2016-11-14 17:47:43 UTC
I work on an N64 emulator (GLupeN64). I received a report from a user that they had garbled output from the application. They tried it with llvmpipe and it worked.

The issue report is here:

It includes and apitrace and a screenshot.

I had him disable indirect drawing, and in that mode the application will use glDrawElementsBaseVertex instead of glDrawElementsIndirect. He said that that fixed the issue, but it was very slow.
Comment 1 Aaron Paden 2016-11-15 01:57:09 UTC
Created attachment 127970 [details]
api traces

Hi, I am the original reporter. At Logan's request, I'm uploading an archive with apitraces when I was using llvmpipe and when I was using radeonsi. In both cases, GLupeN64 was compiled with DEBUG=1 in the makefile.
Comment 2 Nicolai Hähnle 2016-11-16 11:40:51 UTC
Hi Aaron, thanks for the traces. The playback of both traces looks fine to me on Tonga. So either this has been fixed very recently, or it's SI/Oland-specific.

I'm curious, could you please post your dmesg and the output of sha1sum $(find /lib/firmware -iname *oland*)?
Comment 3 Aaron Paden 2016-11-17 01:14:43 UTC
Created attachment 128031 [details]

I use mesa-git nightly builds, and I can confirm the issue is still present as of commit a456ea17fb460a68e28c13dd4b7086dc4309f410. I've also tested a 4.9+amdgpu kernel, but I get the same issue. It could very well be an SI problem.

I'm attaching a dmesg log, and here's the checksums for my firmware.

a76a67f56034921ca495e1cff1cf23d100e280c3  /usr/lib/firmware/radeon/oland_rlc.bin
5f732aca7ab1b205c382002aa2ae6c7b2ff484c9  /usr/lib/firmware/radeon/oland_ce.bin
3428168970dac070766cc50b06221319085214f6  /usr/lib/firmware/radeon/oland_mc.bin
fae6d65d03c902657545ea90c6ea831e6d5b315d  /usr/lib/firmware/radeon/oland_me.bin
d54dc87ffae276aa20c7bccf38cbd9d119aaa149  /usr/lib/firmware/radeon/OLAND_pfp.bin
a0b616a90df665daee7e3de32a1ca8aaa1488280  /usr/lib/firmware/radeon/OLAND_mc2.bin
9a431b9b52ce5d2d9ff8f2e834791760d7d53867  /usr/lib/firmware/radeon/oland_pfp.bin
a0b616a90df665daee7e3de32a1ca8aaa1488280  /usr/lib/firmware/radeon/OLAND_mc.bin
e140372cea171e36ecaa3183ecb5bad69fd73955  /usr/lib/firmware/radeon/OLAND_smc.bin
2aeae1582b8d6064a5a905f24db5baf2009de507  /usr/lib/firmware/radeon/oland_smc.bin
a9ec09b0558e3542114f7a6725763ebfaa89c7e8  /usr/lib/firmware/radeon/OLAND_me.bin
9cda1adf01acdbf7de9171524828603b74edfcd6  /usr/lib/firmware/radeon/OLAND_ce.bin
d8842a871808212514f300344c9f3e336282e525  /usr/lib/firmware/radeon/oland_k_smc.bin
9e85706d8fd514934f1ca1d45b2569d45dcb976e  /usr/lib/firmware/radeon/OLAND_rlc.bin
Comment 4 Timothy Arceri 2018-03-31 23:43:43 UTC
Hi Aaron are you still having issues with current Mesa?
Comment 5 GitLab Migration User 2019-09-25 17:55:22 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1240.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.