Bug 98793 - pulseaudio fails to build from git master using jhbuild
Summary: pulseaudio fails to build from git master using jhbuild
Status: RESOLVED FIXED
Alias: None
Product: PulseAudio
Classification: Unclassified
Component: build-system (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: pulseaudio-bugs
QA Contact: pulseaudio-bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 96750
  Show dependency treegraph
 
Reported: 2016-11-20 10:18 UTC by Mohammed Sadiq
Modified: 2016-12-09 12:06 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
pulseaudio buildlog (50.91 KB, text/x-c)
2016-11-20 10:18 UTC, Mohammed Sadiq
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mohammed Sadiq 2016-11-20 10:18:44 UTC
Created attachment 128080 [details]
pulseaudio buildlog

building pulseaudio from current git master fails.
Build log attached.

Possible relevant part from log:
In file included from modules/xen/module-xenpv-sink.c:52:0:
/usr/include/xs.h:1:2: warning: #warning xs.h is deprecated use xenstore.h instead [-Wcpp]
 #warning xs.h is deprecated use xenstore.h instead
  ^~~~~~~
modules/xen/module-xenpv-sink.c:141:1: error: unknown type name ‘xc_evtchn’
 xc_evtchn* xce;
 ^~~~~~~~~
modules/xen/module-xenpv-sink.c:142:1: error: unknown type name ‘evtchn_port_or_error_t’
 evtchn_port_or_error_t xen_evtchn_port;
 ^~~~~~~~~~~~~~~~~~~~~~
modules/xen/module-xenpv-sink.c: In function ‘xen_cleanup’:
modules/xen/module-xenpv-sink.c:246:5: warning: implicit declaration of function ‘xc_evtchn_notify’ [-Wimplicit-function-declaration]
     xc_evtchn_notify(xce, xen_evtchn_port);
     ^~~~~~~~~~~~~~~~
modules/xen/module-xenpv-sink.c:248:5: warning: implicit declaration of function ‘xc_evtchn_close’ [-Wimplicit-function-declaration]
     xc_evtchn_close(xce);
     ^~~~~~~~~~~~~~~
modules/xen/module-xenpv-sink.c: In function ‘module_xenpv_sink_LTX_pa__init’:
modules/xen/module-xenpv-sink.c:418:11: warning: implicit declaration of function ‘xc_evtchn_open’ [-Wimplicit-function-declaration]
     xce = xc_evtchn_open(NULL, 0);
           ^~~~~~~~~~~~~~
modules/xen/module-xenpv-sink.c:418:9: warning: assignment makes pointer from integer without a cast [-Wint-conversion]
     xce = xc_evtchn_open(NULL, 0);
         ^
modules/xen/module-xenpv-sink.c:425:23: warning: implicit declaration of function ‘xc_evtchn_bind_unbound_port’ [-Wimplicit-function-declaration]
     xen_evtchn_port = xc_evtchn_bind_unbound_port(xce, 0);


Thanks.
Comment 1 Tanu Kaskinen 2016-11-20 11:05:12 UTC
It seems that Xen has at some point broken backwards compatibility. I can reproduce the error with libxen version 4.8.0~rc5-1 (Debian testing). I have no idea when the build has stopped working, because I've always been built PulseAudio without Xen support.

Marking as a release blocker.
Comment 2 Tanu Kaskinen 2016-12-04 18:45:41 UTC
Do you actually use module-xenpv-sink? If not, you can pass --disable-xen to the configure script to disable it.

The plan is to remove module-xenpv-sink in the next release. According to the module author, it's likely not being used by anyone[1]. Of course, if you're using it, we need a new plan.

[1] https://lists.freedesktop.org/archives/pulseaudio-discuss/2016-November/027172.html
Comment 3 Mohammed Sadiq 2016-12-05 00:40:34 UTC
(In reply to Tanu Kaskinen from comment #2)
> Do you actually use module-xenpv-sink? 
No

> If not, you can pass --disable-xen to
> the configure script to disable it.
Thanks. Shall do that.

> Of course, if
> you're using it, we need a new plan.

No I'm not using it directly. It gets build because that's how JHBuild has been configured by default. I don't know if any JHBuild module have a dependency on this specific feature.

Thanks
Comment 4 Tanu Kaskinen 2016-12-05 20:21:20 UTC
Patch submitted:
https://patchwork.freedesktop.org/patch/125645/
Comment 5 Tanu Kaskinen 2016-12-09 12:06:23 UTC
Patch applied.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.