Bug 98980 - GTX 980 (GM204) displays only a black screen.
Summary: GTX 980 (GM204) displays only a black screen.
Status: NEW
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-03 02:29 UTC by Zach Wolfe
Modified: 2017-01-06 16:32 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg output. (84.43 KB, text/plain)
2016-12-03 02:29 UTC, Zach Wolfe
no flags Details
xorg.0.log (76.67 KB, text/plain)
2016-12-03 02:30 UTC, Zach Wolfe
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zach Wolfe 2016-12-03 02:29:42 UTC
Created attachment 128314 [details]
dmesg output.

First, I suspect this is the same problem plaguing the 970 4GB cards however I have lost track of the progress and can't tell anymore if the 980 4GB was part of this. If this is a duplicate I do apologizing. 

I run two GPUs and 3 monitors. The GTX 760 I keep in the 1st PCI slot so I can boot up. The GTX 980 has never worked on LinuxMint (Linux version 4.4.0-51 to date). The PC will boot, the monitor plugged into the GTX 980 will power on however only a black screen is displayed (just as many of the 970 4GB stories I've read). 

Attached is a DMESG log and a xorg.0 log. 

Line 881 in the dmesg log it picks up the primary card (GTX 760) and everything proceeds smoothly. At line 1067 nouveau picks up the GTX 980 (GM204) there are several errors in the log, but i'm no developer so its meaningless to me. I just thought the line numbers might help someone.
Comment 1 Zach Wolfe 2016-12-03 02:30:14 UTC
Created attachment 128315 [details]
xorg.0.log
Comment 2 Zach Wolfe 2017-01-06 16:12:18 UTC
My NVidia GTX 980 works on Ubuntu Mate 16.10 (kernel series 4.8) but not on Mint 18.1 (kernel series 4.4).
Comment 3 Ilia Mirkin 2017-01-06 16:32:20 UTC
Kernel 4.4 did not have any acceleration support for GM20x, that support was added in Kernel 4.6, in the presence of the nvidia-supplied firmware.

Nothing in your original logs seems wrong to me. Perhaps you never configured offloading properly? (Sometimes the desktop manager will do it for you, depends on ... the desktop manager, version, and, I'm sure, its configuration.)

See https://nouveau.freedesktop.org/wiki/Optimus/ specifically the bit about "using outputs on discrete gpu".


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.