Bug 98992 - Latest version of XQuartz breaks nedit
Summary: Latest version of XQuartz breaks nedit
Alias: None
Product: XQuartz
Classification: Unclassified
Component: Other (show other bugs)
Version: 2.7.11 (xserver-1.18.4)
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
Depends on:
Reported: 2016-12-04 23:59 UTC by peterf
Modified: 2016-12-05 05:56 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description peterf 2016-12-04 23:59:58 UTC
I tried installing the latest XQuartz and it seemed to work fine until I tried running nedit. I got the following error:

Shell widget nedit has zero width and/or height.

I tried a bunch of stuff and eventually gave up and reverted to an older version of XQuartz (2.7.9).  I guess I won't be updating that unless this can be fixed.
Comment 1 Jeremy Huddleston Sequoia 2016-12-05 05:56:36 UTC
This is a motif bug.  Use the workaround mentioned in our release notes.

A flat_namespace version of libXt is available in /opt/X11/lib/flat_namespace to help ease the transition (#96292)
Set DYLD_LIBRARY_PATH=/opt/X11/lib/flat_namespace when executing older non-compliant software (eg: Motif-based applications)
Motif users are encouraged to file bugs against Motif to encourage them to fix that library.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.