Bug 99014 - clover is broken for Oland in 12.0.4
Summary: clover is broken for Oland in 12.0.4
Status: RESOLVED WONTFIX
Alias: None
Product: Mesa
Classification: Unclassified
Component: Other (show other bugs)
Version: 12.0
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: 99553
  Show dependency treegraph
 
Reported: 2016-12-07 07:07 UTC by Igor Gnatenko
Modified: 2018-08-21 17:28 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Gnatenko 2016-12-07 07:07:09 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1402259

clpeak when mesa 12.0.4 is installed:
Platform: Clover
  Device: AMD OLAND (DRM 2.46.0 / 4.8.11-300.fc25.x86_64, LLVM 3.8.0)
    Driver version  : 12.0.4 (Linux x64)
    Compute units   : 5
    Clock frequency : 680 MHz

    Global memory bandwidth (GBPS)
      float   : radeon: The kernel rejected CS, see dmesg for more information.
radeon: The kernel rejected CS, see dmesg for more information.
radeon: The kernel rejected CS, see dmesg for more information.
radeon: The kernel rejected CS, see dmesg for more information.
(messages repeated)

dmesg has garbage like this:
[ 1444.937817] [drm:si_vm_reg_valid.part.24 [radeon]] *ERROR* Invalid register 0x950c in CS
[ 1444.937818]  0xc0012800
[ 1444.937819]  0x80000000
[ 1444.937819]  0x80000000
[ 1444.937819]  0xc0026900
...

Expected results:

clpeak after downgrading to mesa 12.0.3:

Platform: Clover
  Device: AMD OLAND (DRM 2.46.0 / 4.8.11-300.fc25.x86_64, LLVM 3.8.0)
    Driver version  : 12.0.3 (Linux x64)
    Compute units   : 5
    Clock frequency : 680 MHz

    Global memory bandwidth (GBPS)
      float   : 23.72
      float2  : 24.14
      ...
Comment 1 Igor Gnatenko 2016-12-07 07:09:13 UTC
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen
Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Oland
GL [FirePro W2100]

The machine is using the Intel integrated graphics for video output.

The AMD card has no monitors attached to it. It's only used for GPGPU computing
via OpenCL.
Comment 2 Michel Dänzer 2016-12-07 07:11:51 UTC
Can you bisect which commit broke it?
Comment 3 Igor Gnatenko 2016-12-07 07:24:37 UTC
(In reply to Michel Dänzer from comment #2)
> Can you bisect which commit broke it?
Unfortunately it's not my bugreport. In theory, I could build RPMs for reporter, but it would take some time. Does it worth it?
Comment 4 Vedran Miletić 2016-12-07 11:28:12 UTC
(In reply to Igor Gnatenko from comment #3)
> (In reply to Michel Dänzer from comment #2)
> > Can you bisect which commit broke it?
> Unfortunately it's not my bugreport. In theory, I could build RPMs for
> reporter, but it would take some time. Does it worth it?

Yes. Was it working in 12.0 or before?
Comment 5 Igor Gnatenko 2016-12-07 11:49:31 UTC
(In reply to Vedran Miletić from comment #4)
> (In reply to Igor Gnatenko from comment #3)
> > (In reply to Michel Dänzer from comment #2)
> > > Can you bisect which commit broke it?
> > Unfortunately it's not my bugreport. In theory, I could build RPMs for
> > reporter, but it would take some time. Does it worth it?
> 
> Yes. Was it working in 12.0 or before?
It was working in 12.0.3 and works in 13.0.2
Comment 6 Emil Velikov 2016-12-07 16:00:11 UTC
Considering Marek's strong request on 12.0.6 can we bisect this please ?

It should require up-to 5-6 steps (using -- src/gallium).
Comment 7 Emil Velikov 2016-12-07 16:00:36 UTC
As usual -> please give 12.0.5 a try first.
Comment 8 Jan Vesely 2016-12-07 18:00:31 UTC
12.0.4 is working fine* on r600 (turks).
Looks like SI compute problem.


*fine: within limits of what I know was broken in LLVM 3.8
Comment 9 Vedran Miletić 2016-12-16 15:19:23 UTC
Not reproducible on Hawaii.
Comment 10 Vedran Miletić 2017-03-22 16:20:34 UTC
Igor, can you test 12.0.6?
Comment 11 Timothy Arceri 2018-08-21 01:55:04 UTC
Support for mesa 12.0 ended long ago and the bug reports the issue was gone in 13.0 so marking as wont fix.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.