Bug 99036 - [BYT] Unable to purge GPU memory due lock contention.
Summary: [BYT] Unable to purge GPU memory due lock contention.
Status: RESOLVED DUPLICATE of bug 99048
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-09 17:15 UTC by Mark Janes
Modified: 2016-12-10 18:46 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2016-12-09 17:15:46 UTC
BYT intermittently report the following dmesg error when executing piglit:

   Unable to purge GPU memory due lock contention.

Subsequently, the machine fails other GPU test suites, and eventually hard-hangs.

I've performed hundreds of piglit runs on byt to reproduce this intermittent issue.  The earliest I have seen it is:

029e8ff81c65c2e0562be4a5d93fe83a9df49233
radv: Initialize the shader_stats_dump flag.

It's likely that this is triggered by a i965 commit just prior to 029e8ff.  I will continue to test in an attempt to identify the regression more precisely.
Comment 1 Mark Janes 2016-12-10 18:46:28 UTC

*** This bug has been marked as a duplicate of bug 99048 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.