Bug 99082 - Missing battery level for Microsoft Designer mouse
Summary: Missing battery level for Microsoft Designer mouse
Status: RESOLVED DUPLICATE of bug 92370
Alias: None
Product: upower
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-14 13:35 UTC by Elvis Angelaccio
Modified: 2018-01-20 16:41 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Elvis Angelaccio 2016-12-14 13:35:33 UTC
Hi,
not sure if this is the right place for this request. Anyway, I got the Microsoft Designer bluetooth mouse, but its battery does not show up in `upower -d`. Any chance this could be fixed?
Comment 1 Richard Hughes 2016-12-14 19:53:58 UTC
Without the hardware it's really hard to implement. Are there any linux tools that can read the battery level, even command line tools?
Comment 2 Elvis Angelaccio 2016-12-14 19:59:11 UTC
(In reply to Richard Hughes from comment #1)
> Without the hardware it's really hard to implement. Are there any linux
> tools that can read the battery level, even command line tools?

I don't know about spcific tools. Plasma can send notifications when the battery level is low [1], I think they query upower via dbus?

[1]: http://blog.broulik.de/2015/02/power-management-in-5-3/
Comment 3 Bastien Nocera 2017-03-23 17:43:22 UTC
(In reply to Elvis Angelaccio from comment #2)
> (In reply to Richard Hughes from comment #1)
> > Without the hardware it's really hard to implement. Are there any linux
> > tools that can read the battery level, even command line tools?
> 
> I don't know about spcific tools. Plasma can send notifications when the
> battery level is low [1], I think they query upower via dbus?

Which is also what "upower -d" does. So it's using something else.
Comment 4 Elvis Angelaccio 2018-01-20 16:41:51 UTC
It seems upower 0.99.7 implemented support for this mouse: https://cgit.freedesktop.org/upower/commit/?id=ccb1b0ed96baf5937d1bc36d5b4b0c65eb873964

(Thanks Bastien!)

Closing as duplicate.

*** This bug has been marked as a duplicate of bug 92370 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.