Bug 99101 - broken man pages in wayland-1.12.0
Summary: broken man pages in wayland-1.12.0
Status: RESOLVED MOVED
Alias: None
Product: Wayland
Classification: Unclassified
Component: wayland (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Wayland bug list
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-15 15:58 UTC by Jose
Modified: 2018-06-08 23:49 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
patch to add *.c.3 and *.h.3 man files to the install script (793 bytes, patch)
2016-12-15 15:58 UTC, Jose
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jose 2016-12-15 15:58:11 UTC
Created attachment 128487 [details] [review]
patch to add *.c.3 and *.h.3 man files to the install script

Some of the man pages installed have links to non-existent files. When running mandb I see lots of warnings like this:
$ sudo mandb -c
......
mandb: can't open /usr/share/man/man3/wayland-server.c.3: No such file or directory
mandb: warning: /usr/share/man/man3/wl_socket_lock.3.gz: bad symlink or ROFF `.so' request
.....

When trying to look at the man page for wl_socket_lock I get this:
$ man wl_socket_lock
man: can't open /usr/share/man/man3/wayland-server.c.3: No such file or directory
No manual entry for wl_socket_lock

This happens with version 1.12.0 and also on today's git's master 721e0b4a9.

This is caused by the install scripts not installing some files that some man pages point to. I attach a patch that fixes the problem on my system: it adds the missing *.c.3 and *.h.3 files to the installation.
Comment 1 GitLab Migration User 2018-06-08 23:49:51 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/wayland/wayland/issues/35.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.