Bug 99210 - ES3-CTS.functional.texture.mipmap.cube.generate.rgba5551_*
Summary: ES3-CTS.functional.texture.mipmap.cube.generate.rgba5551_*
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Chad Versace
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 99228 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-12-27 23:24 UTC by Dylan Baker
Modified: 2017-01-03 16:26 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dylan Baker 2016-12-27 23:24:49 UTC
bisected to e2d69d5e2da0208b7e66c342fbe5323161df2e51.
Comment 1 Kenneth Graunke 2016-12-28 02:44:24 UTC
Not for me.  I think it's the one before that:

commit f3739810e337d0f03514b9b967594c8dc010dfa4
Author: Chad Versace <chadversary@chromium.org>
Date:   Thu Dec 22 14:39:44 2016 -0800

    mesa/texformat: Handle GL_RGBA + GL_UNSIGNED_SHORT_5_5_5_1
Comment 2 Kenneth Graunke 2016-12-28 03:26:38 UTC
looks like some obnoxious precision problem?

you can reproduce this with dEQP too - no need for khronos internal stuff.

dEQP-GLES3.functional.texture.mipmap.cube.generate.rgba5551_fastest
Comment 3 Chad Versace 2016-12-28 20:24:44 UTC
Assigning to self.
Comment 4 Chad Versace 2016-12-29 21:27:58 UTC
Patch submitted.

https://patchwork.freedesktop.org/patch/129670/
https://lists.freedesktop.org/archives/mesa-dev/2016-December/139067.html

From: Chad Versace <chadversary@chromium.org>
Subject: [PATCH] meta: Disable dithering during glGenerateMipmap
Date: Thu, 29 Dec 2016 13:25:57 -0800
Message-Id: <20161229212557.124163-1-chadversary@chromium.org>
Comment 5 Mark Janes 2016-12-30 08:22:22 UTC
On G33, the 2d version of these tests fail as well as the cube map.
Comment 6 Mark Janes 2016-12-30 08:22:44 UTC
*** Bug 99228 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.