Bug 99215 - AMDgpu freeze results in color corruption (red artifacts) in X on every subsequent boot
Summary: AMDgpu freeze results in color corruption (red artifacts) in X on every subse...
Status: RESOLVED DUPLICATE of bug 99078
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/AMDgpu (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-28 21:13 UTC by James Le Cuirot
Modified: 2016-12-29 11:23 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Le Cuirot 2016-12-28 21:13:32 UTC
This is a weird one. I was playing the Talos Principle while hacking xboxdrv to support the Steam Controller. While switching windows, it got into an odd state and the whole display froze. I was able to ssh in from another machine and issue a reboot but after losing contact, it didn't actually reboot. I hit the power button.

When X came back up, it had weird red artifacts all over the place. It's hard to describe so here's a screenshot.

https://aura-online.co.uk/~chewi/red.png

I tried rebooting again. Same thing. I'm on Gentoo so I tried upgrading/downgrading various things but nothing has made any difference. I was then notified of a Gentoo forum thread where another user had encountered the same thing following some kind of crash or freeze in QuDos (Quake 2). This is his screenshot.

https://s24.postimg.org/lbh9ah339/screenshot_20161223_110633.png

The only thing I upgraded since the previous reboot that could possibly be related was LLVM from 3.9.0 to 3.9.1. I haven't downgraded that because it takes ages to build and I doubt that is the cause.

I have fired up the Talos Principle again in the hope that it would knock things back into the shape. The game looks fine but the desktop remains unchanged.

I tried firing up Weston (which I don't normally use) and it didn't show the same corruption when I launched Thunar. That may be a red herring. Excuse the pun. :)

linux: 4.9 (and 4.8.14)
xorg-server: 1.18.4
xf86-video-amdgpu: b5c189473d (and 1.2.0)
libdrm: eebefaf72c (and 2.4.74)
llvm: 3.9.1
mesa: 13.0.2
Comment 1 James Le Cuirot 2016-12-28 21:14:49 UTC
Sorry, forgot the most important bit, it's an RX 480.
Comment 2 Laurent carlier 2016-12-28 21:25:59 UTC

*** This bug has been marked as a duplicate of bug 99078 ***
Comment 3 Andy Furniss 2016-12-29 10:30:31 UTC
This involves llvm change anyway, but more generally, rebooting or (soft) power off really doesn't totally reset GPUs.

You need to shutdown/soft power off the best you can and then totally cut power by turning off PSU switch or unplugging. You should then wait a couple of minutes to be sure everything has "drained" before powering up again.
Comment 4 James Le Cuirot 2016-12-29 11:23:57 UTC
(In reply to Andy Furniss from comment #3)
> This involves llvm change anyway, but more generally, rebooting or (soft)
> power off really doesn't totally reset GPUs.
> 
> You need to shutdown/soft power off the best you can and then totally cut
> power by turning off PSU switch or unplugging. You should then wait a couple
> of minutes to be sure everything has "drained" before powering up again.

Yeah, I actually meant shutdown so power was off but I didn't wait long. Good to know this can still be a factor, thanks.

Sorry for the duplicate, I honestly didn't think LLVM is involved in rendering desktop icons. I've rebuilt without that commit and all is good now.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.