Bug 99325 - [skl] GPU hang in Xorg
Summary: [skl] GPU hang in Xorg
Status: NEEDINFO
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Rainbert
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-08 23:03 UTC by Rainbert
Modified: 2017-01-12 22:23 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
error state batch buffer (45.27 KB, application/gzip)
2017-01-08 23:03 UTC, Rainbert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainbert 2017-01-08 23:03:40 UTC
Created attachment 128819 [details]
error state batch buffer

For half a year I have been experiencing regular GPU hangs in my arch linux KDE4/Plasma installation on a Lenovo Thinkpad X1 Carbon 4th generation (2016). 

It *only* happens when I am using libreoffice word processing software: While typing text, the computer would spontaneously freeze for 10-20 secs, input is interrupted but I can move the mouse, then a notification appears in the system tray reading 
"KWin Window Manager 
Desktop effects were restarted due to graphics reset.", 
and then I can continue working. 

(The notification is similar to this message: https://i.imgur.com/DSgAQBZ.png ) 

The hang occurs regularly every 2-5 minutes but only while using libreoffice. 

Sometimes, about 1 in 10 cases, the mouse pointer freezes as well and the X-Server would crash after 10-20 seconds instead of recovering. 

The bug has been persistent through diverse system updates I did during the last half year. 


File with GPU error state attached. 

Do you need additional information? 
Thanks a lot.
Comment 1 Mark Janes 2017-01-09 18:13:59 UTC
Thank you for reporting this.

Some GPU Hangs in Xorg have been confirmed to be fixed by recent changes to xf86-video-intel.  Can you please attempt to reproduce this using modesetting?

https://bugs.freedesktop.org/show_bug.cgi?id=98999
Comment 2 Rainbert 2017-01-10 23:01:54 UTC
Thanks for this recommendation. I was indeed only using DRI2. 
After installing xf86-video-intel, DRI3 was activated and I could not reproduce the hang. 

So I consider the problem resolved! Thant's extremely cool, thanks! 


(BTW: I don't really no what modesetting is and if activating DRI3 is already equivalent to "using modesetting" as you were writing. If I do 
# cat /sys/module/i915/parameters/modeset 
I still get -1. Dunno if this means anything ...)
Comment 3 Mark Janes 2017-01-12 17:30:12 UTC
Modesetting is an alternative to SNA, which causes the gpu hang that you experienced.  Rather than updating xf86-video-intel, you could avoid using it by adding this X11 config file:

/etc/X11/xorg.conf.d/20-modesetting.conf

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "modesetting"
    Option      "AccelMethod"    "glamor"
    Option      "DRI"            "3"
EndSection

*** This bug has been marked as a duplicate of bug 98999 ***
Comment 4 Chris Wilson 2017-01-12 21:14:00 UTC
Not the same bug, this is in mesa.
Comment 5 Mark Janes 2017-01-12 22:02:08 UTC
Chris, please help me understand how this is a mesa bug if the originator fixed it by compiling latest xf86-video-intel.
Comment 6 Mark Janes 2017-01-12 22:23:39 UTC
Rainbert, can you please provide more information about your configuration?  What version of xf86-video-intel is working for you?

If you switch to modesetting, does the bug reappear?  Can you attach your xorg log from a session where the GPU hang occured?


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.