Bug 99404 - libinput 1.6rc1 gives way to slow accelleration on Dell high precision touchpad
Summary: libinput 1.6rc1 gives way to slow accelleration on Dell high precision touchpad
Status: RESOLVED DUPLICATE of bug 99383
Alias: None
Product: Wayland
Classification: Unclassified
Component: libinput (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Wayland bug list
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-14 08:31 UTC by John Obaterspok
Modified: 2017-01-14 12:24 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
libinput-list-devices (4.71 KB, text/plain)
2017-01-14 08:31 UTC, John Obaterspok
Details
evemu-record (38.11 KB, text/plain)
2017-01-14 08:44 UTC, John Obaterspok
Details
udevadm info (1.34 KB, text/plain)
2017-01-14 08:49 UTC, John Obaterspok
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Obaterspok 2017-01-14 08:31:16 UTC
Created attachment 128947 [details]
libinput-list-devices

Updating from 1.5.3 to libinput-1.5.901-1.fc25.x86_64 makes the speed of the touchpad really slow on a Dell XPS 9550 (2016/Skylake) with high precision touchpad really slow.

In order to make it rather usable I had to turn up the acceleration in system to max.
Comment 1 John Obaterspok 2017-01-14 08:44:18 UTC
Created attachment 128948 [details]
evemu-record

One finger movement from right to left in about less than a second at max acceleration setting moves cursor to about 75% distance from right.
Comment 2 John Obaterspok 2017-01-14 08:49:46 UTC
Created attachment 128949 [details]
udevadm info

Info for Dell Touchpad (/sys/class/input/event15). Also added info for event7.
Comment 3 John Obaterspok 2017-01-14 08:51:13 UTC
# cat /sys/class/dmi/id/modalias
dmi:bvnDellInc.:bvr1.2.18:bd12/01/2016:svnDellInc.:pnXPS159550:pvr:rvnDellInc.:rn0Y9N5X:rvrA01:cvnDellInc.:ct9:cvr:
Comment 4 John Obaterspok 2017-01-14 12:24:01 UTC
Notice it was an entry for this bug already. I have a Full HD screen as well so it's not related to HiDPI

*** This bug has been marked as a duplicate of bug 99383 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.