Bug 99456 - Firefox crashing when opening about:support with WebGL2 enabled
Summary: Firefox crashing when opening about:support with WebGL2 enabled
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-19 05:54 UTC by Clément Guérin
Modified: 2017-01-25 01:49 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Backtrace with debugging symbols (3.28 KB, text/plain)
2017-01-19 08:24 UTC, Michel Dänzer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Clément Guérin 2017-01-19 05:54:06 UTC
Stack:
- firefox 50.1.0
- linux 4.8.13 and 4.10-RC4
- xorg-server 1.19.1
- mesa 17.0 180653c357
- llvm 5.0 292441

Hardware:
- R9 Fury

Steps to reproduce:
- open firefox
- open about:config
- set webgl.enable-webgl2 key to true
- open about:support
- firefox will crash with the following backtrace

#0  0x00007ffff7bc6ad0 in pthread_mutex_lock () at /usr/lib/libpthread.so.0
#1  0x00007fffc1de0d2c in  () at /usr/lib/xorg/modules/dri/radeonsi_dri.so
#2  0x00007fffc1de13fb in  () at /usr/lib/xorg/modules/dri/radeonsi_dri.so
#3  0x00007fffc1e00e82 in  () at /usr/lib/xorg/modules/dri/radeonsi_dri.so
#4  0x00007fffc1f39eff in  () at /usr/lib/xorg/modules/dri/radeonsi_dri.so
#5  0x00007fffc211df49 in  () at /usr/lib/xorg/modules/dri/radeonsi_dri.so
#6  0x00007fffc23c61a7 in  () at /usr/lib/xorg/modules/dri/radeonsi_dri.so
#7  0x00007fffc23c83eb in  () at /usr/lib/xorg/modules/dri/radeonsi_dri.so
#8  0x00007fffc23d9a30 in  () at /usr/lib/xorg/modules/dri/radeonsi_dri.so
#9  0x00007fffc2135634 in  () at /usr/lib/xorg/modules/dri/radeonsi_dri.so
#10 0x00007fffc21353e7 in  () at /usr/lib/xorg/modules/dri/radeonsi_dri.so
#11 0x00007ffff7bc4454 in start_thread () at /usr/lib/libpthread.so.0
#12 0x00007ffff6e607df in clone () at /usr/lib/libc.so.6

Thread 48 "si_shader:1" received signal SIGSEGV, Segmentation fault.

Firefox Developer Edition from flatpak works properly.
Comment 1 Clément Guérin 2017-01-19 05:59:22 UTC
No crash with mesa 13.0.3 and llvm 3.9.1.
Comment 2 Michel Dänzer 2017-01-19 08:20:21 UTC
Any chance you can bisect Mesa with LLVM 3.9?
Comment 3 Michel Dänzer 2017-01-19 08:24:23 UTC
Created attachment 129042 [details]
Backtrace with debugging symbols
Comment 4 Clément Guérin 2017-01-19 18:35:14 UTC
I did some bisecting yesterday, didn't have to finish but I'm really close. I'll update later today.
Comment 5 Clément Guérin 2017-01-19 19:04:44 UTC
bf75ef3f9201e11bb08a4d03dab20d5ff86f1ebc is the first bad commit
commit bf75ef3f9201e11bb08a4d03dab20d5ff86f1ebc
Author: Marek Olšák <marek.olsak@amd.com>
Date:   Tue Nov 15 21:15:55 2016 +0100

    radeonsi: remove all varyings for depth-only rendering or rasterization off
    
    Tested-by: Edmondo Tommasina <edmondo.tommasina@gmail.com>
    Reviewed-by: Nicolai Hähnle <nicolai.haehnle@amd.com>
Comment 6 Marek Olšák 2017-01-19 23:24:29 UTC
Does this commit fix it?
https://cgit.freedesktop.org/mesa/mesa/commit/?id=35cd7551a443477147293e562d8c1adfbe00dea9
Comment 7 Clément Guérin 2017-01-19 23:52:29 UTC
Hi Marek,

No, the mesa build I was using when hitting the bug already included this commit.

I also tried with e0674e740bf8 (current master~1) and I get a crash too.
Comment 8 Clément Guérin 2017-01-25 01:49:40 UTC
It looks like d9ef54923804d5fe44a1d3ad5c29e9b8e8382359 fixed the bug. Thanks, Marek!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.