Bug 99510 - cl_khr_fp64 is reported as supported, but is not, on CAYMAN
Summary: cl_khr_fp64 is reported as supported, but is not, on CAYMAN
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: 13.0
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 96881 99553
  Show dependency treegraph
 
Reported: 2017-01-24 01:15 UTC by Benji Wiebe
Modified: 2019-09-18 19:22 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benji Wiebe 2017-01-24 01:15:06 UTC
On CAYMAN, cl_khr_fp64 is listed as a supported extension in clinfo, and therefore also makes some kernels fail to compile due to their trying to compile in things that need cl_khr_fp64 support. This causes clpeak to fail with 'unsupported call to function __floatunsidf in compute_dp_v1'.

If you need more information I will be happy to provide more.
Comment 1 GitLab Migration User 2019-09-18 19:22:41 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/596.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.