Bug 99525 - [SKL] GPU HANG: ecode 9:0:0x85dfbcfb, in siemcy [3440], reason: Hang on render ring, action: reset
Summary: [SKL] GPU HANG: ecode 9:0:0x85dfbcfb, in siemcy [3440], reason: Hang on rende...
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 12.0
Hardware: Other All
: medium normal
Assignee: bhatcher
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-25 01:22 UTC by bhatcher
Modified: 2019-09-25 18:59 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
GPU crash dump file (762.57 KB, text/plain)
2017-01-25 01:22 UTC, bhatcher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bhatcher 2017-01-25 01:22:50 UTC
Created attachment 129132 [details]
GPU crash dump file

Bug description: Having random reboot issues with the system, but usually not accompanied by this GPU hang. Dual displays running @ 4k60. After the random reboots, both displays work during boot but DP1 does not display once X has loaded.

[68833.361334] [drm] GPU HANG: ecode 9:0:0x85dfbcfb, in siemcy [3440], reason: Hang on render ring, action: reset
[68833.361335] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[68833.361335] [drm] Please file a new bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[68833.361335] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[68833.361335] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[68833.361336] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[68833.361351] drm/i915: Resetting chip after gpu hang
[68833.361405] [drm] RC6 on
[68833.373251] [drm] GuC firmware load skipped
[68844.433130] drm/i915: Resetting chip after gpu hang
[68844.433165] [drm] RC6 on
[68844.447297] [drm] GuC firmware load skipped

System Environment:
-- Chipset: Intel i7-6770HQ with Iris HD 580 GPU
-- Sys Architecture: 64-bit
-- xf86-video-intel: not installed
-- xserver: 1:7.7+13ubun / 2:1.18.4-0ub
-- mesa: 1:12.1~git16
-- libdrm: 2.4.71+git16
-- kernel: GNU/Linux 4.9.0-040900-generic x86_64
-- Linux Distro: Ubuntu 16.04.1 LTS
-- Machine Model: Intel Skull Canyon NUC (NUC6i7KYK)
-- Display connector: DP1 is mDP->HDMI, DP2 is HDMI

Reproducing steps: Unknown
Comment 1 bhatcher 2017-01-27 01:55:22 UTC
I'm happy to provide what additional info I can, if someone can tell me what would be helpful.
Comment 2 yann 2017-01-30 16:09:54 UTC
(In reply to bhatcher from comment #1)
> I'm happy to provide what additional info I can, if someone can tell me what
> would be helpful.

bhatcher@oblong.com, there are constant improvements pushed in kernel and Mesa that will benefit to your system, so please re-test with latest kernel & Mesa (13) and:

- mark as REOPENED if you can reproduce (and attach fresh gpu error dump & kernel log, & you may also collect and attach logs collected thanks to apitrace: http://apitrace.github.io/)). You may also have a try with i915.enable_rc6=0 in your boot command line parameter.

- otherwise RESOLVED/* if you cannot reproduce (but confirm your final config for traceability)
Comment 3 GitLab Migration User 2019-09-25 18:59:59 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1564.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.