Bug 99535 - GPU hangs
Summary: GPU hangs
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-25 15:44 UTC by Keks Dose
Modified: 2017-07-24 22:39 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Keks Dose 2017-01-25 15:44:32 UTC
Kernel: 4.9.4-1-default, openSuse Tumbleweed

After resume from s2disk, PC hangs, screen flickers and desktop is unresponsive.

dmesg includes these lines after wakeup:

[22470.597775] [drm] GPU HANG: ecode 8:0:0xba399353, in Xorg [1652], reason: 
Hang on render ring, action: reset
[22470.597778] [drm] GPU hangs can indicate a bug anywhere in the entire gfx 
stack, including userspace.
[22470.597780] [drm] Please file a _new_ bug report on bugs.freedesktop.org 
against DRI -> DRM/Intel
[22470.597781] [drm] drm/i915 developers can then reassign to the right 
component if it's not a kernel issue.
[22470.597782] [drm] The gpu crash dump is required to analyze gpu hangs, so 
please always attach it.
[22470.597784] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[22470.597865] drm/i915: Resetting chip after gpu hang
[22479.589147] drm/i915: Resetting chip after gpu hang
[22480.078992] Uhhuh. NMI received for unknown reason 3c on CPU 0.
[22480.078995] Do you have a strange power saving mode enabled?
[22480.078997] Dazed and confused, but trying to continue
[22491.589009] drm/i915: Resetting chip after gpu hang
[22503.620918] drm/i915: Resetting chip after gpu hang
[22515.588830] drm/i915: Resetting chip after gpu hang
[22527.588757] drm/i915: Resetting chip after gpu hang
[22539.588682] drm/i915: Resetting chip after gpu hang
[22551.588603] drm/i915: Resetting chip after gpu hang
[22562.596511] drm/i915: Resetting chip after gpu hang
[22573.604415] drm/i915: Resetting chip after gpu hang
[22584.580419] drm/i915: Resetting chip after gpu hang
[22595.620296] drm/i915: Resetting chip after gpu hang
[22607.588250] drm/i915: Resetting chip after gpu hang
[22617.604150] drm/i915: Resetting chip after gpu hang
[22629.604064] drm/i915: Resetting chip after gpu hang
[22641.603976] drm/i915: Resetting chip after gpu hang
[22651.619902] drm/i915: Resetting chip after gpu hang
[22662.627872] drm/i915: Resetting chip after gpu hang
[22675.587746] drm/i915: Resetting chip after gpu hang


============================================

dmesg | grep "error"
[    9.446992] tpm tpm0: A TPM error (6) occurred attempting to read a pcr 
value
[    9.453848] iwlwifi 0000:03:00.0: Direct firmware load for 
iwlwifi-7265D-26.ucode failed with error -2
[    9.453861] iwlwifi 0000:03:00.0: Direct firmware load for 
iwlwifi-7265D-25.ucode failed with error -2
[    9.453869] iwlwifi 0000:03:00.0: Direct firmware load for 
iwlwifi-7265D-24.ucode failed with error -2
[    9.453876] iwlwifi 0000:03:00.0: Direct firmware load for 
iwlwifi-7265D-23.ucode failed with error -2
[21923.165360] tpm tpm0: A TPM error (6) occurred attempting to read a pcr 
value
[22456.293200] tpm tpm0: A TPM error (6) occurred attempting to read a pcr 
value
[22470.597784] [drm] GPU crash dump saved to /sys/class/drm/card0/error


linux-k2bd:/home/AW # dmesg | grep "*ERROR*"
[21923.880843] [drm:intel_dp_start_link_train [i915]] *ERROR* failed to enable 
link training
[21923.965787] [drm:intel_dp_start_link_train [i915]] *ERROR* failed to start 
channel equalization
[21930.417303] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU 
pipe B FIFO underrun
Comment 1 yann 2017-01-30 17:53:49 UTC
There is missing information to proceed.

Please update your system to latest kernel, xf86-video-intel & mesa, then re-test and mark as REOPENED ((Attach as well kernel log and gpu crash dump from /sys/class/drm/card0/error) if you can reproduce and RESOLVED/* if you cannot reproduce.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.