Bug 99566 - [SNB] GPU HANG: ecode 6:0:0x85fffffc, in compiz [17500], reason: Hang on render ring, action: reset
Summary: [SNB] GPU HANG: ecode 6:0:0x85fffffc, in compiz [17500], reason: Hang on rend...
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ted van den Brink
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-27 15:10 UTC by Ted van den Brink
Modified: 2019-09-25 19:00 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
GPU crash dump (147.32 KB, application/gzip)
2017-01-27 15:10 UTC, Ted van den Brink
Details
dmesg (16.62 KB, application/gzip)
2017-01-27 15:11 UTC, Ted van den Brink
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ted van den Brink 2017-01-27 15:10:28 UTC
Created attachment 129180 [details]
GPU crash dump

Architecture: x86_64
Kernel: 4.8.0-34-generic
Distro: Ubuntu 16.10
Machine: Samsung RC720
Using built-in display and external display over VGA

I'm not sure what triggers this, it seems to be happening when Chrome Beta is running.
Comment 1 Ted van den Brink 2017-01-27 15:11:14 UTC
Created attachment 129181 [details]
dmesg
Comment 2 yann 2017-01-30 09:54:01 UTC
According to mesa engineers, mesa only emits 3DSTATE_VERTEX_ELEMENTS on-demand right before 3DPRIMITIVE.

Chris has changed SNA to emit a dummy primitive between VertexElements in  4acd4a7d3d2f41227022fa7581cfb85a0b124eae in xf86-video-intel (thanks to https://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=4acd4a7d3d2f41227022fa7581cfb85a0b124eae)

So I recommend to update to latest version of xf86-video-intel since fix should be already in and mark as REOPENED if you can reproduce (and attach fresh gpu error dump) and RESOLVED/* if you cannot reproduce.

An alternate solution is to use Glamor/modesetting, but 1st try this one.

========================
*Details:
- Kernel: 4.8.0-34-generic
- Platform: SandyBridge (PCI ID: 0x0116, PCI Revision: 0x09, PCI Subsystem: 144d:c0b2)
- Mesa: [Please confirm your version]
- xf86-video-intel: [Please confirm your version]

From this error dump, hung is happening in render ring batch with active head at 0x7a09d574, with 0x7a000003 (PIPE_CONTROL) as IPEHR.

Batch extract (around 0x7a09d574):

0x7a09d52c:      0x78090005: 3DSTATE_VERTEX_ELEMENTS
0x7a09d530:      0x02000000:    buffer 0: valid, type 0x0000, src offset 0x0000 bytes
0x7a09d534:      0x11110000:    (X, Y, Z, W), dst offset 0x00 bytes
0x7a09d538:      0x02000010:    buffer 0: valid, type 0x0000, src offset 0x0010 bytes
0x7a09d53c:      0x11110000:    (X, Y, Z, W), dst offset 0x00 bytes
0x7a09d540:      0x02000020:    buffer 0: valid, type 0x0000, src offset 0x0020 bytes
0x7a09d544:      0x11110000:    (X, Y, Z, W), dst offset 0x00 bytes
0x7a09d548:      0x7b001804: 3DPRIMITIVE: tri fan sequential
0x7a09d54c:      0x00000004:    vertex count
0x7a09d550:      0x00000000:    start vertex
0x7a09d554:      0x00000001:    instance count
0x7a09d558:      0x00000000:    start instance
0x7a09d55c:      0x00000000:    index bias
0x7a09d560:      0x7a000003: PIPE_CONTROL
0x7a09d564:      0x00100002:    no write, cs stall, stall at scoreboard,
0x7a09d568:      0x00000000:    destination address
0x7a09d56c:      0x00000000:    immediate dword low
0x7a09d570:      0x00000000:    immediate dword high
0x7a09d574:      0x7a000003: PIPE_CONTROL
0x7a09d578:      0x00004000:    qword write,
0x7a09d57c:      0x00b57004:    destination address
0x7a09d580:      0x00000000:    immediate dword low
0x7a09d584:      0x00000000:    immediate dword high
0x7a09d588:      0x780e0002: 3DSTATE_CC_STATE_POINTERS
0x7a09d58c:      0x00007c01:    blend change 1
0x7a09d590:      0x00000000:    depth stencil change 0
0x7a09d594:      0x00000000:    cc change 0
Comment 3 GitLab Migration User 2019-09-25 19:00:10 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1568.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.