Bug 99637 - VLC video has corrupted colors when using VDPAU output on Radeon SI
Summary: VLC video has corrupted colors when using VDPAU output on Radeon SI
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: 17.0
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-02 01:19 UTC by Matt Whitlock
Modified: 2017-02-06 15:10 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Whitlock 2017-02-02 01:19:06 UTC
Two reports of this so far on Gentoo when using Mesa 17.0.0 RC2.

See a screenshot here:
https://bugs.gentoo.org/attachment.cgi?id=461558

I am reporting this bug upstream (i.e., here) at the request of Gentoo dev Matt Turner.

Here is the Gentoo bug report:
https://bugs.gentoo.org/show_bug.cgi?id=607368

The problem disappears upon downgrading to Mesa 13.0.3.

Mateusz Lenik, the reporter of the bug on Gentoo's tracker, is using a Polaris 10 card, and I am using a Tobago (Bonaire Pro) card. We are both using the "radeonsi" VDPAU driver.
Comment 1 Nayan Deshmukh 2017-02-02 05:23:34 UTC
The problem is already fixed in the master branch. This patch fixes the issue.

Commit: 31908d6a4a3309f4cd4b953d6eecdf41595b1299

   st/vdpau: only send buffers with B8G8R8A8 format to X
   PresentPixmap only works if the pixmap depth matches with the
   window depth, otherwise it returns a BadMatch protocol error.
   Even if the depths match, the result won't look correctly
   if the VDPAU RGB component order doesn't match the X11 one so
   we only allow the X11 format.
   For other buffers we copy them to a buffer which is send to X.

   v2: only send buffers with format VDP_RGBA_FORMAT_B8G8R8A8
   v3: reword commit message
   v4: add comment explaining the code

   Signed-off-by: Nayan Deshmukh <nayan26deshmukh@gmail.com>
   Reviewed-by: Christian König <christian.koenig@amd.com>

Can you test with this patch?
Comment 2 Matt Whitlock 2017-02-02 09:03:20 UTC
(In reply to Nayan Deshmukh from comment #1)
> Can you test with this patch?

Applying the patch to 17.0.0 RC2 solves the problem. Thanks.
Comment 3 Michel Dänzer 2017-02-02 09:06:34 UTC
This report should remain open until the fix lands on the 17.0 branch.
Comment 4 Nayan Deshmukh 2017-02-02 09:17:36 UTC
(In reply to Michel Dänzer from comment #3)
> This report should remain open until the fix lands on the 17.0 branch.

I will nominate the patch for the 17.0 branch.
Comment 5 Nayan Deshmukh 2017-02-06 15:10:03 UTC
The patch has landed on 17.0.0-rc3.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.