Bug 9965 - on Unichrome an accelerated window is displayed at double coordinates of window itself
on Unichrome an accelerated window is displayed at double coordinates of wind...
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/Unichrome
git
x86 (IA32) Linux (All)
: high major
Assigned To: mesa-dev
:
: 11762 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-13 06:30 UTC by Benno Schulenberg
Modified: 2009-08-24 12:25 UTC (History)
4 users (show)

See Also:


Attachments
patch by Miguel Marte that fixes the problem (2.97 KB, patch)
2007-02-24 05:30 UTC, Benno Schulenberg
Details | Splinter Review
be consistent to avoid doubling up (4.08 KB, patch)
2007-02-25 19:38 UTC, Miguel Marte
Details | Splinter Review
real fix, was working on makecurrent read and sent in the wrong one (4.25 KB, patch)
2007-02-26 11:30 UTC, Miguel Marte
Details | Splinter Review
diff to current git (4.35 KB, patch)
2007-02-26 12:59 UTC, Miguel Marte
Details | Splinter Review
kill off the rest of drawXoff, apply prev patch first (4.66 KB, patch)
2007-02-28 17:20 UTC, Miguel Marte
Details | Splinter Review
remove all uses of Xdrawoffset from unichrome driver (7.99 KB, patch)
2007-03-03 05:29 UTC, Benno Schulenberg
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Benno Schulenberg 2007-02-13 06:30:43 UTC
Bisecting shows that this bug was introduced with commit d7815f59134b0fb5cb3b56b72b22ba55002265ac.

The bug is most clear when slowly moving a glxgears window from the upperleft corner vertically down or horizontally to the right.  The gears themselves move with the window, but the "viewport" moves twice as fast (picking up an echo of the gears some 400 pixels to the right).
Comment 1 Benno Schulenberg 2007-02-15 03:18:50 UTC
Where did this bug go?  I haven't seen it yet on dri-devel or mesa3d-dev.
Comment 2 Benno Schulenberg 2007-02-24 05:30:16 UTC
Created attachment 8832 [details] [review]
patch by Miguel Marte that fixes the problem

Same patch as submitted for review by Miguel Marte in this email:
http://sourceforge.net/mailarchive/message.php?msg_id=38294678
Comment 3 Miguel Marte 2007-02-25 19:38:16 UTC
Created attachment 8848 [details] [review]
be consistent to avoid doubling up
Comment 4 Benno Schulenberg 2007-02-26 03:40:16 UTC
At comment #3: this new patch is not as good as the previous one.   After applying it (and tweaking it to make it compile), the gears in glxgears are "gnawed" to bits (at certain x positions), and are located at double the coordinates of the window itself.
Comment 5 Benno Schulenberg 2007-02-26 03:42:09 UTC
CC'ing Miguel.  See previous comment.
Comment 6 Miguel Marte 2007-02-26 11:30:24 UTC
Created attachment 8856 [details] [review]
real fix, was working on makecurrent read and sent in the wrong one

This should do it :\ sorry for the wrong file.  Can some one tell me why we are even using orig to begin with?
Comment 7 Miguel Marte 2007-02-26 12:59:50 UTC
Created attachment 8857 [details] [review]
diff to current git
Comment 8 Miguel Marte 2007-02-28 17:20:25 UTC
Created attachment 8918 [details] [review]
kill off the rest of drawXoff, apply prev patch first

Kill off the rest of drawXoff, its still affecting the back buffer -> front buffer.  This will fix the offset problems in texenv,gearbox and hopefully the problem Xavier has with the screensaver preview.  One question that i have is, is the first box in gearbox suppose to be the depth buffer?
Comment 9 Benno Schulenberg 2007-03-03 05:29:35 UTC
Created attachment 8961 [details] [review]
remove all uses of Xdrawoffset from unichrome driver

Combines the last two patches by Miguel, plus a parentheses fix and obsolete comment removal.
Comment 10 Brian Paul 2007-03-18 09:08:54 UTC
I've checked in the last patch.  Can this be closed now?
Comment 11 Benno Schulenberg 2007-03-18 13:45:08 UTC
Thanks.
Comment 12 Timo Aaltonen 2007-03-30 01:09:13 UTC
Brian: I can't find the commit, could you give the id?
Comment 13 Benno Schulenberg 2007-03-30 02:47:06 UTC
At comment #13: c41d6ab6f062ebce1076ca79f9ad0c7368a0e2d0
Comment 14 Timo Aaltonen 2007-03-30 14:01:12 UTC
Thanks!
Comment 15 Hans de Bruin 2007-08-04 02:24:22 UTC
*** Bug 11762 has been marked as a duplicate of this bug. ***
Comment 16 ajax at nwnk dot net 2009-08-24 12:25:53 UTC
Mass version move, cvs -> git