Bug 99739 - [SKL][BAT] igt@kms_flip@basic-flip-vs-wf_vblank fails on CI
Summary: [SKL][BAT] igt@kms_flip@basic-flip-vs-wf_vblank fails on CI
Status: CLOSED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium major
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-09 18:49 UTC by Jani Saarinen
Modified: 2017-08-18 19:08 UTC (History)
1 user (show)

See Also:
i915 platform: SKL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jani Saarinen 2017-02-09 18:49:48 UTC
On SKL 6700hq igt@kms_flip@basic-flip-vs-wf_vblank fails on CI.

See: https://intel-gfx-ci.01.org/CI/CI_DRM_2162/fi-skl-6700hq/igt@kms_flip@basic-flip-vs-wf_vblank.html

and dmesg:
https://intel-gfx-ci.01.org/CI/CI_DRM_2162/fi-skl-6700hq/dmesg-during.log
Comment 1 Jani Saarinen 2017-02-10 08:35:48 UTC
Same for other SKL:
https://intel-gfx-ci.01.org/CI/Patchwork_3761/fi-skl-6770hq/igt@kms_flip@basic-flip-vs-wf_vblank.html

GT-Version: 1.17-g0174d22 (x86_64) (Linux: 4.10.0-rc7-CI-Patchwork_3761+ x86_64)
Using monotonic timestamps
Beginning basic-flip-vs-wf_vblank on pipe A, connector DP-2
  1920x1200 60 1920 1968 2000 2080 1200 1203 1209 1235 0x9 0x48 154000
Expected frametime: 16681us; measured 16680.6us +- 4.939us accuracy 0.09%

basic-flip-vs-wf_vblank on pipe A, connector DP-2: PASSED

Beginning basic-flip-vs-wf_vblank on pipe B, connector DP-2
  1920x1200 60 1920 1968 2000 2080 1200 1203 1209 1235 0x9 0x48 154000
Stack trace:
  #0 [__igt_fail_assert+0x101]
  #1 [run_test_on_crtc_set.constprop.14+0x1e6f]
  #2 [<unknown>+0x1e6f]
Subtest basic-flip-vs-wf_vblank: FAIL (2.850s)
Err	
(kms_flip:8686) CRITICAL: Test assertion failure function calibrate_ts, file kms_flip.c:1207:
(kms_flip:8686) CRITICAL: Failed assertion: ev.sequence == last_seq + 1
(kms_flip:8686) CRITICAL: error: 18109 != 18108
Subtest basic-flip-vs-wf_vblank failed.

dmesg:
https://intel-gfx-ci.01.org/CI/Patchwork_3761/fi-skl-6770hq/dmesg-during.log
Comment 2 Ricardo 2017-02-14 16:12:44 UTC
This test passes in the QA side (running one time) in igt fast drm-tip 4.10.0-rc8 6f8a1e0 SKL
Comment 3 Dorota Czaplejewicz 2017-02-16 11:51:34 UTC
Not seen in 32 runs on Celeron(R) CPU G3900. drm-tip: 2017y-02m-16d-10h-06m-42s, config 2192
Comment 5 Jani Saarinen 2017-04-21 15:48:35 UTC
for 
igt@kms_flip@basic-flip-vs-wf_vblank
Last seen: 2017-03-30 (CI_DRM_2441)
Statistics: Failure rate 3/252 run(s) (1%)

igt@kms_flip@basic-flip-vs-wf_vblank
Last seen: 2017-03-03 (CI_DRM_2281)
Statistics: Failure rate 2/274 run(s) (0%)
Comment 6 Jani Saarinen 2017-06-16 08:21:36 UTC
Last seen both same
Statistics: Failure rate 8/432 run(s) (1%)
and 
Statistics: Failure rate 2/454 run(s) (0%)

Based on this resolving.
Comment 8 Elizabeth 2017-07-24 21:57:34 UTC
Good afternoon, 
Changing the importance to "major" since is IGT basic with very sporadic(<20%) reproducibility. Thanks.
Comment 9 Jani Saarinen 2017-08-18 07:13:02 UTC
last seen:
fi-skl-6770hq: CI_DRM_2786: 2017-06-30 / 160 runs. Failure rate of 9 / 725 runs (1 %)
fi-skl-6700hq: CI_DRM_2281: 2017-03-03 / 660 runs. Failure rate of 2 / 726 runs (0 %)

Based on that reolving.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.