Bug 99830 - Multi-touch is pretty picky on finger placement
Summary: Multi-touch is pretty picky on finger placement
Status: RESOLVED MOVED
Alias: None
Product: Wayland
Classification: Unclassified
Component: libinput (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium minor
Assignee: Wayland bug list
QA Contact:
URL:
Whiteboard:
Keywords:
: 100533 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-02-15 19:41 UTC by Taylor
Modified: 2018-06-05 09:58 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Currently Strict Finger Placement (19.45 KB, image/png)
2017-02-15 19:41 UTC, Taylor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Taylor 2017-02-15 19:41:13 UTC
Created attachment 129657 [details]
Currently Strict Finger Placement

So I was digging through the source code attempting to figure out how to resolve this but got lost.

The main issue I am encountering is that when using this library the function calls are only triggered if all 3 fingers are lined up horizontally on the trackpad which makes it really hard to trigger. <<-- most important part of this bug report. 

I am using a Macbook pro 2010 built-in trackpad running elementary os. 

I have 3 finger swipe up tied to super+Up and as a test I had it tied to just a single letter in a text document. It seems that the placement of the fingers on the trackpad determine if it's triggered. The natural position is a triangular pattern for the 3 fingers.

It would be nice in the configuration to be able to set the length of the swipe gesture and maybe a flag to make finger position not important. 

Essentially if any 3 fingers in any spot are on the trackpad (or even defined spots, I don't know how that would work in the config) and the group moves a certain direction and distance at a certain speed threshold. 

That would open up a lot of different possibilities for fast swipe vs slow swipe. swipe to top right or top left. Ect.
Comment 1 Peter Hutterer 2017-04-18 01:53:45 UTC
in case that's not obvious from the long silence - I'm quite busy with other things and haven't found time to work on this yet, sorry.
Comment 2 Peter Hutterer 2017-05-19 05:15:30 UTC
*** Bug 100533 has been marked as a duplicate of this bug. ***
Comment 3 Peter Hutterer 2018-05-01 07:12:05 UTC
somewhat related but not fixing this particular issue:

commit 66687902d01a01f844bf9039150f22e7c10850ef
Author: Peter Hutterer <>
Date:   Thu Apr 26 11:18:58 2018 +1000

     gestures: if two fingers are in definitive pinch position, pinch
Comment 4 GitLab Migration User 2018-06-05 09:58:18 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/libinput/libinput/issues/6.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.