Bug 99860 - Trackpoint sensivity is very high
Summary: Trackpoint sensivity is very high
Status: RESOLVED DUPLICATE of bug 91369
Alias: None
Product: Wayland
Classification: Unclassified
Component: libinput (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Wayland bug list
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-19 10:18 UTC by Vitaly Sulimov
Modified: 2017-05-19 05:41 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
libunput-debug-events logs (2.36 KB, text/plain)
2017-02-19 10:18 UTC, Vitaly Sulimov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vitaly Sulimov 2017-02-19 10:18:01 UTC
Created attachment 129742 [details]
libunput-debug-events logs

I have Fedora 25 running on my Dell Latitude E5570 laptop and trackpoint is soooo sensitive. Just a little touch moves the cursor to another end of the screen, makes it absolutely unusable. I'm attached some logs from libinput-debug-events, hope it can helps.
Comment 1 Peter Hutterer 2017-02-20 00:26:58 UTC
what's the output from udevadm info /sys/class/input/event5 (adjusted for the event node if need be)
Comment 2 Vitaly Sulimov 2017-02-20 03:22:28 UTC
Output for udevadm info /sys/class/input/event5:
P: /devices/platform/i8042/serio1/input/input7/event5
N: input/event5
E: DEVNAME=/dev/input/event5
E: DEVPATH=/devices/platform/i8042/serio1/input/input7/event5
E: ID_BUS=i8042
E: ID_INPUT=1
E: ID_INPUT_MOUSE=1
E: ID_INPUT_POINTINGSTICK=1
E: LIBINPUT_DEVICE_GROUP=11/2/8/800:isa0060/serio1
E: MAJOR=13
E: MINOR=69
E: SUBSYSTEM=input
E: USEC_INITIALIZED=19241595
Comment 3 Peter Hutterer 2017-02-21 23:48:39 UTC
have a look at this file:
https://github.com/systemd/systemd/blob/master/hwdb/70-pointingstick.hwdb

looks like you need an entry with a CONST_ACCEL of less than 1 to slow the thing down a bit. at the top of the file are instructions on how to install a custom hwdb entry for testing
Comment 4 Vitaly Sulimov 2017-02-22 07:06:19 UTC
I'm tried that but it's doesn't work.

My output for/sys/class/dmi/id/modalias
dmi:bvnDellInc.:bvr1.11.3:bd11/14/2016:svnDellInc.:pnLatitudeE5570:pvr:rvnDellInc.:rn0GMHGH:rvrA00:cvnDellInc.:ct9:cvr:

So, I'm created a local rule 
evdev:name:*DualPoint Stick:dmi:bvn*:bvr*:bd*:svnDellInc.:pnLatitudeE5570*:pvr*
 POINTINGSTICK_CONST_ACCEL=0.2

After that I'm update hwdb and execute udevadm trigger /dev/input/event*
But nothing changed. No matter what value I'm set to CONST_ACCEL.
Comment 5 Peter Hutterer 2017-02-22 07:52:58 UTC
does the property show up? 
https://wayland.freedesktop.org/libinput/doc/latest/faq.html#faq_hwdb_changes

If it shows up in udev, does libinput-debug-events --verbose show the const accel value?
Comment 6 Vitaly Sulimov 2017-02-22 08:14:18 UTC
Yes and yes. udevamd test produce this output

ID_INPUT_POINTINGSTICK=1
LIBINPUT_DEVICE_GROUP=11/2/8/800:isa0060/serio1
MAJOR=13
MINOR=69
POINTINGSTICK_CONST_ACCEL=0.5

And libinput-debug-events --verbose 
input device 'AlpsPS/2 ALPS DualPoint Stick', /dev/input/event5 is tagged by udev as: Mouse Pointingstick
Device 'AlpsPS/2 ALPS DualPoint Stick' set to const accel 0.50

But nothing changed in pointstick behavior
Comment 7 Peter Hutterer 2017-02-22 08:31:02 UTC
strange. You restarted X/Wayland, I take it?
Comment 8 Vitaly Sulimov 2017-02-22 09:05:51 UTC
Damn. I've never restart wayland after changes, only hwdb update. Actually, restarting a wayland works. Thank you so much!
Comment 9 languitar 2017-03-03 09:48:32 UTC
I also have a Dell laptop with an ALPS dual pointing stick and had the same issue that the stick was much too fast. However, I am unable to achieve acceptable results with all the different knobs that are available. If I tune down acceleration, I am able to do detailed pointing, but the stick is generally so slow, that it takes ages to cross the screen. On the other hand, if I increase the acceleration, even the slightest movement of the stick makes it jump significantly on the screen so that I am unable to do detailed selections.

Setting POINTINGSTICK_CONST_ACCEL has an effect but as described, not the desired. Is there anything else that can be tuned to get this going?
Comment 10 Peter Hutterer 2017-03-06 05:32:02 UTC
No, there's no other setting exposed right now, sorry. It's a long-standing issue with libinput but no-one has found the time or motivation to work on it yet.
Comment 11 Dominik Wujastyk 2017-04-27 22:25:39 UTC
This fix doesn't work on my Dell E5570, including restarting Xorg.  :-(

Running Linux Mint 18.1 with Cinnamon.  If I stick to an old Kernel, 4.4.0-53 generic, then the mouse is fine.  But if I use any later Kernel, including various versions of 4.8 and 4.10, then the mouse pointer-stick has uncontrollable acceleration.  The touch pad is fine.

Dominik
Comment 12 Peter Hutterer 2017-04-28 00:28:03 UTC
is the property applied in both cases?
Comment 13 Dominik Wujastyk 2017-04-28 19:22:46 UTC
yes, if you mean with both kernels.  Yes.
Comment 14 Dominik Wujastyk 2017-04-28 19:23:41 UTC
... But in fact the lower 4.4 kernel doesn't need the hwdb setting.  The pointer-stick/trackpoint acceleration is fine, out of the box.
Comment 15 Peter Hutterer 2017-05-19 05:41:29 UTC
I think I'm going to close this this as dupe of bug 91369 because it ends up being the same issue. That bug has a test branch in bug 91369#c48, please give that one a try.

*** This bug has been marked as a duplicate of bug 91369 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.