Bug 99867 - GPU Hung when using libreoffice
Summary: GPU Hung when using libreoffice
Status: RESOLVED DUPLICATE of bug 104411
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-20 13:55 UTC by Marco Benatto
Modified: 2018-03-15 20:04 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
GPU erro dump (271.32 KB, text/plain)
2017-02-20 13:55 UTC, Marco Benatto
Details
Xorg log (52.46 KB, text/x-log)
2017-02-20 13:55 UTC, Marco Benatto
Details
dmesg output (68.49 KB, text/plain)
2017-02-20 13:56 UTC, Marco Benatto
Details
gpu crash dump (23.78 KB, text/plain)
2018-03-15 19:25 UTC, floriantoth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Benatto 2017-02-20 13:55:34 UTC
Created attachment 129752 [details]
GPU erro dump

Hello,

I faced a GPU hung when running libreoffice at Fedora 25, the GPU performance started to downgrade right after I've started the application leading to a total screen freeze and a GPU reset, the following message was shown at dmesg:

[ 4877.844879] [drm] GPU HANG: ecode 9:0:0x85dffffb, in Xorg [1315], reason: Hang on render ring, action: reset
[ 4877.844883] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 4877.844885] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[ 4877.844887] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 4877.844888] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 4877.844891] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 4877.845070] drm/i915: Resetting chip after gpu hang
[ 4877.845305] [drm] GuC firmware load skipped
[ 4879.828210] [drm] RC6 on

No more errors or issues was found previously. I've attached the GPU crash dump and Xorg log.

These are the software versions:

Kernel: 4.8.6-300.fc25.x86_64
Xorg: X.Org X Server 1.18.99.901 (1.19.0 RC 1)
VGA Controller: Intel Corporation HD Graphics 520 [8086:1916] (rev 07)
libdrm:2.4.71
mesa-dri-drivers: 12.0.3
Comment 1 Marco Benatto 2017-02-20 13:55:55 UTC
Created attachment 129753 [details]
Xorg log
Comment 2 Marco Benatto 2017-02-20 13:56:16 UTC
Created attachment 129754 [details]
dmesg output
Comment 3 floriantoth 2018-03-15 19:21:09 UTC
Hello,

Same for me:
LibreOffice 5.0.6.2
Scientific Linux release 7.4
Kernel 4.15.0-1.el7.elrepo.x86_64
xorg-x11-server-Xorg 1.19.3
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)
mesa-dri-drivers 17.0.1

My dmesg output reads:
[93418.593258] perf: interrupt took too long (3979 > 3963), lowering kernel.perf_event_max_sample_rate to 50000
[95872.516352] [drm] GPU HANG: ecode 9:0:0x85dffffb, in X [2038], reason: Hang on rcs0, action: reset
[95872.516356] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[95872.516357] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[95872.516358] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[95872.516359] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[95872.516360] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[95872.516367] i915 0000:00:02.0: Resetting rcs0 after gpu hang
[95880.509718] i915 0000:00:02.0: Resetting rcs0 after gpu hang
[95888.510039] i915 0000:00:02.0: Resetting rcs0 after gpu hang
[95896.510253] i915 0000:00:02.0: Resetting rcs0 after gpu hang
[95904.510498] i915 0000:00:02.0: Resetting rcs0 after gpu hang
Comment 4 floriantoth 2018-03-15 19:25:22 UTC
Created attachment 138146 [details]
gpu crash dump

/sys/class/drm/card0/error
Comment 5 Mark Janes 2018-03-15 20:04:54 UTC
These hangs have been fixed in mesa 17.3.6

*** This bug has been marked as a duplicate of bug 104411 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.