Bug 99874 - make recommended system service naming mandatory
Summary: make recommended system service naming mandatory
Status: RESOLVED MOVED
Alias: None
Product: dbus
Classification: Unclassified
Component: core (show other bugs)
Version: git master
Hardware: Other All
: medium enhancement
Assignee: D-Bus Maintainers
QA Contact: D-Bus Maintainers
URL:
Whiteboard:
Keywords:
Depends on: 99825
Blocks:
  Show dependency treegraph
 
Reported: 2017-02-20 16:57 UTC by Simon McVittie
Modified: 2018-10-12 21:30 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon McVittie 2017-02-20 16:57:43 UTC
dbus-daemon currently has the following unintended behaviour for system services whose filenames are not the canonical name (the well-known name + ".service"):

* Parse whichever service came first in readdir() order (might be the canonical name, or any other name[1]).
* Silently ignore any others.
* If the one that got parsed has a SystemdService set, use that for activation.
* If the one that got parsed does not have a SystemdService set, use the setuid helper for activation - but the setuid helper will load the file that has the canonical name instead (!), or if there is none, activation will fail.

When Bug #99825 lands, [1] will at least become a warning.

For the development branch, I think we should consider tightening this to: if the name is not canonical, just fail to load it. After Bug #99825, this would be easy to do.
Comment 1 GitLab Migration User 2018-10-12 21:30:12 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/dbus/dbus/issues/168.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.