Bug 99891 - Xquartz 2.7.11 not compatible with Mac OS Sierra Using Coot by SBGrid
Summary: Xquartz 2.7.11 not compatible with Mac OS Sierra Using Coot by SBGrid
Status: RESOLVED MOVED
Alias: None
Product: XQuartz
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 2.7.11 (xserver-1.18.4)
Hardware: Other Mac OS X (All)
: medium major
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-21 16:58 UTC by Caleb L. Sutton
Modified: 2019-05-23 18:31 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Caleb L. Sutton 2017-02-21 16:58:24 UTC
Sorry for no log, but I'll do my best to describe it.

I was trying to run Coot through SSH from a CentOS6 machine on my Macbook with OS Sierra. Xquartz turned out to be the problem with Coot not opening. We have confirmed with SBGrid that any version of XQuartz after 2.7.9 will break when running Coot and other programs in the SBGrid package. 2.7.9 didn't work for me on Sierra, but did work with someone running an older OS. I had to revert to 2.7.8 to get it to work. We know that older Mac OS's will work with 2.7.9 and a few Linux distros work with the latest 2.7.11.


Not a major issue, but we wanted it to be known that versions 2.7.9-2.7.11 do not work with Sierra. We have contacted SBGrid to see if there is a fix on their end as well.

Thanks
Comment 1 Caleb L. Sutton 2017-02-21 17:01:43 UTC
Found the error:

INFO:: Using Standard CCP4 Refmac dictionary from CLIBD_MON: /programs/x86_64-linux/ccp4/7.0/ccp4-7.0/lib/data/monomers/
INFO:: Reading coordinate file: /export/bwsl1/sbgrid/x86_64-linux/ccp4/7.0/ccp4-7.0/share/coot/standard-residues.pdb
     PDB file /export/bwsl1/sbgrid/x86_64-linux/ccp4/7.0/ccp4-7.0/share/coot/standard-residues.pdb has been read.
    Spacegroup: P 1
The program 'coot-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 299 error_code 2 request_code 149 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
coot-exe: "/export/bwsl1/sbgrid/x86_64-linux/ccp4/7.0/ccp4-7.0/libexec/coot-bin"
coot-version: 
/export/bwsl1/sbgrid/x86_64-linux/ccp4/7.0/ccp4-7.0/libexec/coot-bin
platform: 
/bin/uname
core: #f
No core file found.  No debugging
Comment 2 Jeremy Huddleston Sequoia 2017-02-21 18:40:48 UTC
Please work with SBGrid to figure out what the problem is and file a reduced test case if they believe this is a bug in the X server.
Comment 3 GitLab Migration User 2019-05-23 18:31:49 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/xserver/issues/784.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.