Bug 99943 - xserver (git version): Fatal server error
Summary: xserver (git version): Fatal server error
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Acceleration/glamor (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-24 13:31 UTC by Jos van Wolput
Modified: 2017-03-09 09:55 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.0.log, fatal server error (27.16 KB, text/plain)
2017-02-24 13:31 UTC, Jos van Wolput
no flags Details

Description Jos van Wolput 2017-02-24 13:31:31 UTC
Created attachment 129897 [details]
xorg.0.log, fatal server error

Using the latest git version of xserver (7d7788e0f2fb...) compiled with Debian's
gcc-7 I get the following
Fatal server error:
[  3914.258] (EE) GLSL compile failure

Please see the attached xorg.0.log

No such error when using the released xorg-server-1.19.1 (commit ad2facda30...).
Comment 1 Olivier Fourdan 2017-02-27 13:06:42 UTC
That looks like a regression in glamor, possibly commit be334f4 ?

https://cgit.freedesktop.org/xorg/xserver/commit/?id=be334f4

Can you try to reproduce without that commit?
Comment 2 Jos van Wolput 2017-02-27 14:33:25 UTC
(In reply to Olivier Fourdan from comment #1)
> Can you try to reproduce without that commit?

As you asked I reverted line 199 of glamor_composite_glyphs.c to
---
                "varying vec2 glyph_pos;\n"),
    .vs_exec = (GLAMOR_POS(gl_Position, primitive)
                "       glyph_pos = source.xy * ATLAS_DIM_INV;\n"),
---
and recompiled xserver.

Still getting the same fatal error.
Comment 3 Jos van Wolput 2017-02-27 15:14:51 UTC
(In reply to Olivier Fourdan from comment #1)
> That looks like a regression in glamor, possibly commit be334f4 ?
> 
> https://cgit.freedesktop.org/xorg/xserver/commit/?id=be334f4
> 
> Can you try to reproduce without that commit?

Sorry for my previous message, I first only logged out and in.

After rebooting this error doesn't reproduce anymore!
Reverting commit be334f4 fixes this issue.
Thanks!
Comment 4 Jos van Wolput 2017-02-27 16:33:51 UTC
(In reply to Olivier Fourdan from comment #1)
> That looks like a regression in glamor, possibly commit be334f4 ?
> 
> https://cgit.freedesktop.org/xorg/xserver/commit/?id=be334f4
> 
> Can you try to reproduce without that commit?

I feel very sorry, I messed up the xserver versions I was using.
I now first double checked the used version!

Reverting commit be334f4 doesn't fix the issue,
but it no longer occurs when reverting all glamor to the one
used in xserver version 1.19.1
So the regression seems to be in another glamor file.
Comment 5 Jos van Wolput 2017-02-27 17:47:16 UTC
I did some more research.
Using /git/xserver/glamor and only reverting glamor_dash.c to the version
in xserver-1.19.1 fixes the issue.

This means reverting
static const char dash_vs_exec[] =
    "       dash_offset = primitive.z / dash_length;\n"
    "       vec2_pos = vec2(0,0);\n"
    GLAMOR_POS(gl_Position, primitive.xy);
to
static const char dash_vs_exec[] =
    "       dash_offset = primitive.z / dash_length;\n"
    GLAMOR_POS(gl_Position, primitive.xy);
Comment 6 Michel Dänzer 2017-03-03 02:04:23 UTC
*** Bug 100039 has been marked as a duplicate of this bug. ***
Comment 7 Michel Dänzer 2017-03-09 09:20:30 UTC
Thanks for the report, fixed in Git master:

commit 0c1574d9882a91b2c1a046bf4ac5a9b138a37965
Author: Michel Dänzer <michel.daenzer@amd.com>
Date:   Thu Mar 9 18:13:31 2017 +0900

    glamor: Fix typo: "vec2_pos" -> "vec2 pos"
Comment 8 Jos van Wolput 2017-03-09 09:55:03 UTC
(In reply to Michel Dänzer from comment #7)
 
>     glamor: Fix typo: "vec2_pos" -> "vec2 pos"

No more fatal server error, thanks!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.