Bug 100019 - [bdw] GPU hang and application crash in Pillars of Eternity (steam)
Summary: [bdw] GPU hang and application crash in Pillars of Eternity (steam)
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: vladimir.campos
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 77449
  Show dependency treegraph
 
Reported: 2017-03-01 12:16 UTC by Matthias Blankertz
Modified: 2019-07-04 02:43 UTC (History)
1 user (show)

See Also:
i915 platform: BDW
i915 features: GPU hang


Attachments
dmesg (63.39 KB, text/x-log)
2017-03-01 12:16 UTC, Matthias Blankertz
Details
gpu crash dump (77.16 KB, application/x-bzip)
2017-03-01 12:16 UTC, Matthias Blankertz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Blankertz 2017-03-01 12:16:16 UTC
Created attachment 129998 [details]
dmesg

The game Pillars of Eternity (current steam version) froze on the character level up screen after clicking the next button. The computer froze for a few seconds, then the game crashed. The computer continued running (no system hang). The kernel log ends with: 

[ 8174.996148] [drm] GPU HANG: ecode 8:0:0x85dffffb, in PillarsOfEterni [9281], reason: Hang on render ring, action: reset
[ 8174.996150] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 8174.996150] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[ 8174.996151] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 8174.996151] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 8174.996152] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 8174.996182] drm/i915: Resetting chip after gpu hang

Full kernel log and crash dump attached.

uname -a: Linux matthias-tp 4.9.11-1-ARCH #1 SMP PREEMPT Sun Feb 19 13:45:52 UTC 2017 x86_64 GNU/Linux
Machine: Lenovo Thinkpad L450
Distribution: Arch linux
Display: internal
mesa version: 17.0.0-2 (ARCH)
drm version: 2.4.75-1 (ARCH)
Comment 1 Matthias Blankertz 2017-03-01 12:16:52 UTC
Created attachment 129999 [details]
gpu crash dump
Comment 2 Mark Janes 2017-03-01 16:34:53 UTC
we are going to need an apitrace for this.
Comment 3 Matthias Blankertz 2017-03-01 18:41:18 UTC
That could be difficult, the crash only occurs infrequently and randomly.
Comment 4 Paul 2019-04-26 09:24:23 UTC
Hi guys
I've just tried to reproduce the issue on my BDW (Intel® HD Graphics 5500) with mesa 17.0.0, 18.3.2 and latest master version and Kernel 4.9.11 and 5.0.0. 
I wasn’t able to reproduce the hang.
Matthias, could you please confirm if the issue is fixed or provide more reliable way to replicate it?
Since the issue is old, it can be not reproducible on the newest version of the game and of the mesa.
Thanks


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.