Bug 100356 - [DSI BYT] Panel detection fail
Summary: [DSI BYT] Panel detection fail
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
: 101603 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-03-23 14:59 UTC by Pavel
Modified: 2018-03-08 18:56 UTC (History)
3 users (show)

See Also:
i915 platform: BYT
i915 features: display/DSI


Attachments
4.11 r3 drm-tip WITH Dirty Hack (47.82 KB, text/rtf)
2017-03-23 14:59 UTC, Pavel
no flags Details
4.11 r3 dri-tip W/O Dirty Hack (88.45 KB, text/rtf)
2017-03-23 14:59 UTC, Pavel
no flags Details
4.12 last drm-tip (50.38 KB, text/rtf)
2017-07-13 18:46 UTC, Pavel
no flags Details
4.12 drm-tip debug 0xe (150.63 KB, text/plain)
2017-07-16 19:12 UTC, Pavel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel 2017-03-23 14:59:05 UTC
Created attachment 130397 [details]
4.11 r3 drm-tip WITH Dirty Hack

No screen image on display. Just black with backlight. Fastboot=1 doesn't working. Get fastboot to work by dirty hack:
[
In intel_display.c, I changed the line


FROM

if (i915.fastboot && intel_pipe_config_compare(dev, to_intel_crtc_state(crtc->state), pipe_config, true)) {

TO

if (i915.fastboot) {
]
Now display is working with fastboot=1, but XRANDR detects it as a UNKNOWN. If try to change display orientation, I will get black screen with backlight. 

If I use kernel without dirty hack, it detects DSI panel normally, but it's black.
Comment 1 Pavel 2017-03-23 14:59:40 UTC
Created attachment 130398 [details]
4.11 r3 dri-tip W/O Dirty Hack
Comment 2 Ville Syrjala 2017-06-27 09:52:55 UTC
[    3.073989] [drm:pwm_setup_backlight [i915]] *ERROR* Failed to own the pwm chip

You're missing some pwm/gpio stuff most likely from the kernel (or it got loaded after i915).

Make sure you have at least these:
CONFIG_PWM=y
CONFIG_PWM_CRC=y
CONFIG_I2C_DESIGNWARE_PLATFORM=y
CONFIG_I2C_DESIGNWARE_PCI=y
CONFIG_INTEL_SOC_PMIC=y
Comment 3 Elizabeth 2017-06-27 15:01:49 UTC
*** Bug 101603 has been marked as a duplicate of this bug. ***
Comment 4 Elizabeth 2017-06-27 15:03:04 UTC
(In reply to Elizabeth from comment #3)
> *** Bug 101603 has been marked as a duplicate of this bug. ***

Bug 101603 is the same case. Please check the logs provided by Parker. Thank you.

Adding tag into "Whiteboard" field - ReadyForDev
*Status is correct
*Platform is included
*Feature is included
*Priority and Severity correctly set
*Logs included
Comment 5 Elizabeth 2017-06-29 22:10:08 UTC
Hello Pavel,
Were you able to test with the parameters that Ville mention?

(In reply to Ville Syrjala from comment #2)
> [    3.073989] [drm:pwm_setup_backlight [i915]] *ERROR* Failed to own the
> pwm chip
> 
> You're missing some pwm/gpio stuff most likely from the kernel (or it got
> loaded after i915).
> 
> Make sure you have at least these:
> CONFIG_PWM=y
> CONFIG_PWM_CRC=y
> CONFIG_I2C_DESIGNWARE_PLATFORM=y
> CONFIG_I2C_DESIGNWARE_PCI=y
> CONFIG_INTEL_SOC_PMIC=y

If so, please share results? Thank you.
Comment 6 Jani Nikula 2017-07-04 12:42:36 UTC
(In reply to Elizabeth from comment #5)
> Hello Pavel,
> Were you able to test with the parameters that Ville mention?
> 
> (In reply to Ville Syrjala from comment #2)
> > [    3.073989] [drm:pwm_setup_backlight [i915]] *ERROR* Failed to own the
> > pwm chip
> > 
> > You're missing some pwm/gpio stuff most likely from the kernel (or it got
> > loaded after i915).
> > 
> > Make sure you have at least these:
> > CONFIG_PWM=y
> > CONFIG_PWM_CRC=y
> > CONFIG_I2C_DESIGNWARE_PLATFORM=y
> > CONFIG_I2C_DESIGNWARE_PCI=y
> > CONFIG_INTEL_SOC_PMIC=y
> 
> If so, please share results? Thank you.

If those help, this is a dupe of bug 96571.
Comment 7 Pavel 2017-07-12 17:10:06 UTC
Now backlight is working, but I still have bug with rotation. Just merged last drm-tip. I have black screen without hack, with hack I have image, but when I am trying to reinit panel (xrandr --off && --auto), or connect HDMI, or rotate, I have black screen
Comment 8 Pavel 2017-07-12 17:12:39 UTC
Also now I see DSI1 instead of UNKNOWN in Xrandr. add_efi_memmap helped me
Comment 9 Pavel 2017-07-13 18:46:14 UTC
Created attachment 132672 [details]
4.12 last drm-tip
Comment 10 Pavel 2017-07-13 19:24:00 UTC
Also if i try to use xrandr --off, --auto will not start display, it will be black
Comment 11 Ville Syrjala 2017-07-13 20:15:02 UTC
(In reply to Pavel from comment #9)
> Created attachment 132672 [details]
> 4.12 last drm-tip

Not much info there. Please do these steps:

1. Remove all this stuff from the kernel command line:
   "fbcon=rotate:1 i915.modeset=1 i915.fastboot=1 enable_fbc=1 enable_psr=0"
2. Add drm.debug=0xe instead
3. Boot drm-tip
4. Attach dmesg, and please make it plain text instead of rtf
Comment 12 Pavel 2017-07-16 19:12:07 UTC
Created attachment 132718 [details]
4.12 drm-tip debug 0xe
Comment 13 Ville Syrjala 2017-08-25 12:13:25 UTC
(In reply to Pavel from comment #12)
> Created attachment 132718 [details]
> 4.12 drm-tip debug 0xe

[    2.954679] [drm:intel_dsi_init [i915]] *ERROR* Failed to own gpio for panel control
[    2.954783] [drm:pwm_setup_backlight [i915]] *ERROR* Failed to own the pwm chip

So looks like you might still be missing some of the needed kernel config options listed in comment 2.

[    4.026941] i2c_designware 80860F41:00: controller timed out
[    4.054787] i2c_designware 80860F41:00: timeout in disabling adapter
[    4.077474] i2c_designware 80860F41:00: timeout waiting for bus ready

And it looks like there's something wrong with i2c. Not sure if those might affect the display as well somehow. At least we don't do any direct i2c banging from DSI code so these shouldn't be coming directly from i915 at least.
Comment 14 Pavel 2017-08-28 08:33:17 UTC
I have this kernel options. Also I already tried hack for timeout on i2c. It didn't work.
Comment 15 Pavel 2018-03-01 18:49:22 UTC
Last merge of drm-tip fixed everything! 4.16-rc3.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.