Bug 101603 - [i915] LCD panel not initialized on BayTrail
Summary: [i915] LCD panel not initialized on BayTrail
Status: CLOSED DUPLICATE of bug 100356
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-26 19:05 UTC by Parker Reed
Modified: 2017-06-30 21:36 UTC (History)
3 users (show)

See Also:
i915 platform: BYT
i915 features: display/Other


Attachments
Boot log (211.97 KB, text/plain)
2017-06-26 19:05 UTC, Parker Reed
no flags Details
Kernel config (187.22 KB, text/plain)
2017-06-26 19:05 UTC, Parker Reed
no flags Details
Screenshot on "working" DV8P (217.79 KB, image/png)
2017-06-27 03:03 UTC, Parker Reed
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Parker Reed 2017-06-26 19:05:29 UTC
Created attachment 132261 [details]
Boot log

Hardware: Dell Venue 8 Pro (5830), board revision 09RP78, BIOS A14 01/28/2016

Software: Kernel 4.12-rc7 (also tested rc5 and rc6) pulled straight from git. Grub bootloader handing off both native resolution and EFI resolution.

Description: LCD panel stays blank after i915 tries to initialize. Backlight is active and I cannot see anything on screen.

Current kernel config and boot log attached
Comment 1 Parker Reed 2017-06-26 19:05:50 UTC
Created attachment 132262 [details]
Kernel config
Comment 2 Parker Reed 2017-06-27 03:03:45 UTC
Created attachment 132270 [details]
Screenshot on "working" DV8P

So after doing some digging I ran across this issue https://bugs.freedesktop.org/show_bug.cgi?id=100356

Having all else fail, I figured I'd try the "hacky" method. Already had drm-tip cloned and compiled, so I just made that one change and recompiled. Installed and added the fastboot to my kernel args. It actually comes up and KMS works. As noted in the issue, an xrandr rotate does kill the output, but mine does show DSI info instead of "UNKNOWN"
Comment 3 Elizabeth 2017-06-27 15:01:49 UTC
I'm going to mark this as a duplicated from 10356, since it seems to be the same problem in the same platform. Thanks for the information.

*** This bug has been marked as a duplicate of bug 100356 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.