Bug 100400 - [Solved] Game Valhalla Hills crash on startup
Summary: [Solved] Game Valhalla Hills crash on startup
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: 17.0
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-26 09:09 UTC by beham.christopher
Modified: 2017-07-11 23:15 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Output of the game execution logged with script (33.91 KB, application/octet-stream)
2017-03-26 09:09 UTC, beham.christopher
Details
gdb output of running and backtracing the game logged with script (50.50 KB, text/plain)
2017-03-26 09:10 UTC, beham.christopher
Details
glxinfo (102.32 KB, application/octet-stream)
2017-03-26 09:11 UTC, beham.christopher
Details
lspci (4.27 KB, application/octet-stream)
2017-03-26 09:11 UTC, beham.christopher
Details
cpuinfo (5.00 KB, application/octet-stream)
2017-03-26 09:12 UTC, beham.christopher
Details
Source files packagecreation archlinux with enabled debug (28.80 KB, application/x-xz)
2017-03-26 09:16 UTC, beham.christopher
Details
valgrind output of the game execution logged with script (343.39 KB, text/plain)
2017-03-28 20:36 UTC, beham.christopher
Details
valgrind output with less missing debug info (469.70 KB, application/x-xz)
2017-04-01 17:01 UTC, beham.christopher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description beham.christopher 2017-03-26 09:09:26 UTC
Created attachment 130460 [details]
Output of the game execution logged with script

The Game Valhalla Hills crashes for me on Mesa 17.0.2 on Archlinux.

I tried the mesa packages from the standard archlinux extra repo.
To get a little bit more information I added the line '--enable-debug \' to ./configure in the mesa_archlinux_package_source_files and created the packages and installed the packages mesa and mesa-vdpau, except from builded with enabled debug these packages are the same as from the standard archlinux extra repo.

The attached file run is the output of executing:
ST_DEBUG=tgsi MESA_DEBUG=1 LIBGL_DEBUG=verbose ./ValhallaHills-Linux-Shipping

The attached file gdb is the output of executing:
ST_DEBUG=tgsi MESA_DEBUG=1 LIBGL_DEBUG=verbose gdb ./ValhallaHills-Linux-Shipping

I also tried to play with MESA_GL_VERSION_OVERRIDE (the game seems to need at least 3.2) and MESA_GLSL_VERSION_OVERRIDE (the game seems to need at least 150) but with no effects on the error outputs.

The game works very well when using the amdgpu-pro driver version 16.60.379184 and turning off vsync in the game options. But I want to keep Mesa because of the need to downgrade packages for amdgpu-pro and bad performance on Grid Autosport. 

The game also works with an old nvidia GeForce GT240 in my old PC in my cellar with both nvidia version 340 and mesa nouveau driver, with colour and blinking light issues but quite playable.
Comment 1 beham.christopher 2017-03-26 09:10:36 UTC
Created attachment 130461 [details]
gdb output of running and backtracing the game logged with script
Comment 2 beham.christopher 2017-03-26 09:11:06 UTC
Created attachment 130462 [details]
glxinfo
Comment 3 beham.christopher 2017-03-26 09:11:47 UTC
Created attachment 130463 [details]
lspci
Comment 4 beham.christopher 2017-03-26 09:12:10 UTC
Created attachment 130464 [details]
cpuinfo
Comment 5 beham.christopher 2017-03-26 09:16:31 UTC
Created attachment 130465 [details]
Source files packagecreation archlinux with enabled debug
Comment 6 Samuel Pitoiset 2017-03-28 00:16:18 UTC
Thanks for this very nice report. :)

I can reproduce the issue with mesa/LLVM from today.
Comment 7 Michel Dänzer 2017-03-28 02:27:56 UTC
valgrind might give more information.
Comment 8 beham.christopher 2017-03-28 20:36:44 UTC
Created attachment 130515 [details]
valgrind output of the game execution logged with script

Thanks for your replies, I ran valgrind with:

ST_DEBUG=tgsi MESA_DEBUG=1 LIBGL_DEBUG=verbose valgrind --error-limit=no ./ValhallaHills-Linux-Shipping

Please let me know if there are other options which could be useful to get better information.
Comment 9 beham.christopher 2017-04-01 17:01:08 UTC
Created attachment 130633 [details]
valgrind output with less missing debug info

Because I saw there is very much missing debug info in the first valgrind file I recompiled the affected libs with debug symbols.

The new valgrind file was generated with this line:

ST_DEBUG=tgsi MESA_DEBUG=1 LIBGL_DEBUG=verbose valgrind --leak-check=full --show-leak-kinds=all --track-origins=yes --error-limit=no ./ValhallaHills-Linux-Shipping
Comment 10 CraZy bisCuiT 2017-04-25 21:54:47 UTC
This problem affects me as well on mesa 17.04 and llvm 4.0.0-1 with AMD RX 480. Any ideas what causes this problem?

We can't expect a patch from the developer since the studio doesn't exist anymore. For some reason proprietary AMD and nVidia drivers do work.
Comment 11 Samuel Pitoiset 2017-05-22 08:38:40 UTC
Hi there,

The crash at startup can no longer be reproduced. I have just tested with Mesa (4eb0411ed72) and LLVM (9031fd91990). Though, it still crashes with Mesa 17.1.0 and LLVM 4.0.0.

Can you upgrade LLVM and confirm, please?
Comment 12 beham.christopher 2017-05-23 16:50:03 UTC
(In reply to Samuel Pitoiset from comment #11)
> Hi there,
> 
> The crash at startup can no longer be reproduced. I have just tested with
> Mesa (4eb0411ed72) and LLVM (9031fd91990). Though, it still crashes with
> Mesa 17.1.0 and LLVM 4.0.0.
> 
> Can you upgrade LLVM and confirm, please?

Hi,

I can confirm it is now working with current mesa-git and llvm-svn with both radeon and amdgpu driver.

Thanks for your work.
Comment 13 CraZy bisCuiT 2017-07-11 23:15:04 UTC
Thanks for fixing! With the current mesa-git and llvm-svn it seems to work flawlessly!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.