Bug 100905 - [SKL] GPU hang when using LibreOffice
Summary: [SKL] GPU hang when using LibreOffice
Status: RESOLVED DUPLICATE of bug 99720
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-02 17:03 UTC by Paul-Antoine Arras
Modified: 2017-06-25 11:40 UTC (History)
1 user (show)

See Also:
i915 platform: SKL
i915 features:


Attachments
Xorg log (35.27 KB, text/x-log)
2017-05-02 17:03 UTC, Paul-Antoine Arras
Details
/sys/class/drm/card0/error (76.60 KB, application/x-bzip)
2017-05-02 17:04 UTC, Paul-Antoine Arras
Details
dmesg (20.43 KB, application/x-bzip)
2017-05-02 17:05 UTC, Paul-Antoine Arras
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul-Antoine Arras 2017-05-02 17:03:09 UTC
Created attachment 131172 [details]
Xorg log

Bug description:
When I use LibreOffice Writer, after a few minutes, the whole GUI freezes (except the mouse that continues to move but click is inoperative) and X restarts.
The relevant diagnostic from dmesg is:
[drm] GPU HANG: ecode 9:0:0x85dffffb, in Xorg [879], reason: Hang on render ring, action: reset

System environment:
-- chipset (`lspci -v`): 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06) (prog-if 00 [VGA controller])
-- system architecture: x86_64
-- xf86-video-intel: xserver-xorg-video-intel: 2:2.99.917+git20161206-1
-- xserver: xserver-xorg-core: 2:1.19.2-1
-- mesa: 13.0.6-1+b2
-- libdrm: 2.4.74-1
-- kernel: 4.9.0-2-amd64
-- Linux distribution: Debian Stretch
-- Machine or mobo model: Dell Precision 7710

Reproducing steps:
Open LO Writer, type some text, scroll page, change window...
After a few minutes, everything freezes, not only LO.

Additional info:
Comment 1 Paul-Antoine Arras 2017-05-02 17:04:09 UTC
Created attachment 131173 [details]
/sys/class/drm/card0/error
Comment 2 Paul-Antoine Arras 2017-05-02 17:05:26 UTC
Created attachment 131174 [details]
dmesg
Comment 3 Paul-Antoine Arras 2017-05-03 16:36:47 UTC
Forgot to mention that I have hybrid graphics.
The discrete GPU is [AMD/ATI] Venus XTX [Radeon HD 8890M / R9 M275X/M375X] (rev 83).
Comment 4 Paul-Antoine Arras 2017-05-28 21:11:30 UTC
Possible duplicate of Bug 100794.
Comment 5 Jan Drewes 2017-06-25 06:41:53 UTC
Possible duplicate of Bug 99720.
Comment 6 Paul-Antoine Arras 2017-06-25 11:40:58 UTC
(In reply to Jan Drewes from comment #5)
> Possible duplicate of Bug 99720.

Seems so.

*** This bug has been marked as a duplicate of bug 99720 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.