Bug 101774 - gen_clflush.h:37:7: error: implicit declaration of function ‘__builtin_ia32_clflush’
Summary: gen_clflush.h:37:7: error: implicit declaration of function ‘__builtin_ia32_c...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Matt Turner
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 101786 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-07-13 07:10 UTC by Fabio Pedretti
Modified: 2017-07-14 23:55 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
patch (884 bytes, patch)
2017-07-13 18:48 UTC, Matt Turner
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Pedretti 2017-07-13 07:10:02 UTC
Since yesterday building mesa on a 32 bit system gives this error:
../../../../../../../src/intel/common/gen_clflush.h:37:7: error: implicit declaration of function ‘__builtin_ia32_clflush’ [-Werror=implicit-function-declaration]

Full log here:
https://launchpadlibrarian.net/328564504/buildlog_ubuntu-yakkety-i386.mesa_17.2~git1707130730.c3b5c2~gd~y_BUILDING.txt.gz

Builds OK on 64 bit systems.
Comment 1 Matt Turner 2017-07-13 18:47:26 UTC
*** Bug 101786 has been marked as a duplicate of this bug. ***
Comment 2 Matt Turner 2017-07-13 18:48:29 UTC
Created attachment 132673 [details] [review]
patch

I'm not sure if -msse3 will enable clflush, but let's give it a try.
Comment 3 Kenneth Graunke 2017-07-13 20:16:18 UTC
According to https://gcc.gnu.org/onlinedocs/gcc-4.8.5/gcc/X86-Built-in-Functions.html we need -msse2
Comment 4 Matt Turner 2017-07-14 19:39:51 UTC
Patch now on the list
Comment 5 Matt Turner 2017-07-14 23:55:21 UTC
Pushed as

commit 6b05c080f202c25531f59b547d5e6ba339cedd09
Author: Matt Turner <mattst88@gmail.com>
Date:   Thu Jul 6 21:31:05 2017 -0700

    i965: Compile with -msse3


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.