Bug 101786 - mesa master compilation is broken for intel i386 arch
Summary: mesa master compilation is broken for intel i386 arch
Status: RESOLVED DUPLICATE of bug 101774
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-13 17:39 UTC by Paulo Dias
Modified: 2017-07-13 18:47 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paulo Dias 2017-07-13 17:39:39 UTC
make[8]: Entering directory '/<<PKGBUILDDIR>>/build/dri/src/mesa/drivers/dri/i965'
  CC       brw_binding_tables.lo
  CC       brw_blorp.lo
../../../../../../../src/mesa/drivers/dri/i965/brw_blorp.c: In function ?brw_blorp_clear_depth_stencil?:
../../../../../../../src/mesa/drivers/dri/i965/brw_blorp.c:1014:4: warning: ?num_layers? may be used uninitialized in this function [-Wmaybe-uninitialized]
    blorp_clear_depth_stencil(&batch, &depth_surf, &stencil_surf,
    ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
                              level, start_layer, num_layers,
                              ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
                              x0, y0, x1, y1,
                              ~~~~~~~~~~~~~~~
                              (mask & BUFFER_BIT_DEPTH), ctx->Depth.Clear,
                              ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
                              stencil_mask, ctx->Stencil.Clear);
                              ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
../../../../../../../src/mesa/drivers/dri/i965/brw_blorp.c:1014:4: warning: ?start_layer? may be used uninitialized in this function [-Wmaybe-uninitialized]
../../../../../../../src/mesa/drivers/dri/i965/brw_blorp.c:1014:4: warning: ?level? may be used uninitialized in this function [-Wmaybe-uninitialized]
  CC       brw_bufmgr.lo
In file included from ../../../../../../../src/mesa/drivers/dri/i965/brw_bufmgr.c:59:0:
../../../../../../../src/intel/common/gen_clflush.h: In function ?gen_clflush_range?:
../../../../../../../src/intel/common/gen_clflush.h:37:7: error: implicit declaration of function ?__builtin_ia32_clflush? [-Werror=implicit-function-declaration]
       __builtin_ia32_clflush(p);
       ^~~~~~~~~~~~~~~~~~~~~~
../../../../../../../src/intel/common/gen_clflush.h: In function ?gen_flush_range?:
../../../../../../../src/intel/common/gen_clflush.h:45:4: error: implicit declaration of function ?__builtin_ia32_mfence? [-Werror=implicit-function-declaration]
    __builtin_ia32_mfence();
    ^~~~~~~~~~~~~~~~~~~~~
In file included from ../../../../../../../src/mesa/drivers/dri/i965/brw_bufmgr.c:60:0:
../../../../../../../src/mesa/drivers/dri/i965/brw_bufmgr.c: In function ?bo_alloc_internal?:
../../../../../../../src/mesa/drivers/dri/i965/brw_bufmgr.c:370:8: warning: format ?%ld? expects argument of type ?long int?, but argument 5 has type ?uint64_t {aka long long unsigned int}? [-Wformat=]
    DBG("bo_create: buf %d (%s) %ldb\n", bo->gem_handle, bo->name, size);
        ^
../../../../../../../src/intel/common/gen_debug.h:94:41: note: in definition of macro ?dbg_printf?
 #define dbg_printf(...) fprintf(stderr, __VA_ARGS__)
                                         ^~~~~~~~~~~
../../../../../../../src/mesa/drivers/dri/i965/brw_bufmgr.c:370:4: note: in expansion of macro ?DBG?
    DBG("bo_create: buf %d (%s) %ldb\n", bo->gem_handle, bo->name, size);
    ^~~
cc1: some warnings being treated as errors
Makefile:1122: recipe for target 'brw_bufmgr.lo' failed

mesa git up to 655a32f729a46176c1fc0c1727b33c15c69cad78
ubuntu zesty 17.04
Comment 1 Matt Turner 2017-07-13 18:47:26 UTC

*** This bug has been marked as a duplicate of bug 101774 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.