Bug 102885 - regression - 17.2 sparkle grid in shadows
Summary: regression - 17.2 sparkle grid in shadows
Status: RESOLVED DUPLICATE of bug 105152
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: 17.2
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-19 20:38 UTC by Thomas J. Moore
Modified: 2018-09-08 06:33 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Ugly shaded areas (1.16 MB, image/png)
2017-09-19 20:38 UTC, Thomas J. Moore
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas J. Moore 2017-09-19 20:38:39 UTC
Created attachment 134348 [details]
Ugly shaded areas

See attached image.  While I was retesting many games in wine, I noticed that multiple games, when run in wine, show black background with dot grids instead of alpha blending, apparently.  Reverting to 17.1.x fixed this.  I haven't the patience or continuous power to my machine to git-bisect; the only thing I can help with is that it doesn't do this with LIBGL_ALWAYS_SOFTWARE=1, so it's likely a radeonsi bug rather than mesa core.

Hardware:
    Device: AMD Radeon R7 Graphics (AMD CARRIZO / DRM 3.18.0 / 4.13.2-gentoo, LLVM 5.0.0) (0x9874)
OpenGL renderer string: AMD Radeon R7 Graphics (AMD CARRIZO / DRM 3.18.0 / 4.13.2-gentoo, LLVM 5.0.0)

Note that this has been broken since the earliest rc I tried, also with earlier releases of the kernel and llvm, firmware from both before and after 06 Sept.

Apologies if this has already been reported; I can't really tell and it has been broken now for at least all rcs I've tried, 17.2 release, and 17.2.1.
Comment 1 Samuel Pitoiset 2017-09-19 21:12:47 UTC
Can you record a trace with apitrace that reproduces the issue?

If not, which games are affected? What Wine version? Is CSMT enabled?
Comment 2 Thomas J. Moore 2017-09-20 00:25:16 UTC
(In reply to Samuel Pitoiset from comment #1)
> Can you record a trace with apitrace that reproduces the issue?

I could, I guess.  I've never used the tool before, though, and have no idea how to trim it to the relevant part.  I can't attach a 179MB trace file (109M compressed).   I tried trimming to just the relevant region(s), but it's screwy at best, and mostly garbage in the replay, I doubt it's useful.

> If not, which games are affected? What Wine version? Is CSMT enabled?

I dunno.  I erased my notes after I discovered at least 4 broken games; at that point, I realized that these problems only started around the later tests, where Mesa had been auto-updated to 17.2-some rc by my regular system updates, so I stopped blaming wine and tried reverting Mesa instead.  The only ones I still remember are KOTOR (because it was worst) and Chains of Satinav.  The attached picture is from the former; I test the presence of the bug using the latter, because KOTOR often has (unrelated) trouble starting up.  Note that neither game shows this problem all the time:  Satinav only shows it in the cursor when the cursor is over a selectable area, and KOTOR only shows it at certain viewing angles (I don't really know what the difference is).  Both, and others that had issues, displayed brief flashes of dot grids at various other times as well.  I currently use Wine 2.0.2, 2.15, 2.15-staging, and with/without gallium-d3d9.  I can assure you that I tried all combinations of the above when I discovered it didn't work normally.  2.0.2 doesn't use csmt by default, and 2.15 does, so apparently csmt doesn't make a difference.
Comment 3 Samuel Pitoiset 2017-09-20 07:18:33 UTC
Yeah, please upload the trace somewhere. You can use dropbox or some other similar services.
Comment 4 Thomas J. Moore 2017-09-20 15:07:45 UTC
I said I wouldn't, but I went ahead and did a git-bisect:

878bd981bf7aac1466ba3278796f200fa329e2af is the first bad commit

If I have an opportunity later today, I may upload the trace file somewhere.
Comment 5 Thomas J. Moore 2017-09-20 16:40:27 UTC
I'm not sure I trust dropbox entirely (it's a bit invasive), but I went ahead and created an account to upload the trace file:

https://www.dropbox.com/s/uo6kllmpr1b5jrt/satinav.trace?dl=0

This is from Chains of Satinav.  The sparkle grid appears in the large cursor in the middle of the screen when it's hovering over the ship's window.  Normally it is grayish with a wave pattern over it, but when broken, it's just a sparkle grid.  Please let me know if/when you're downloaded it, so I know it worked, and I can delete it.

Note that I got a trace from KOTOR as well, but it is not usably replayable, unlike this one.
Comment 6 Samuel Pitoiset 2017-09-21 07:56:51 UTC
Thanks for the trace (and the bisect), I can reproduce the issue.
Comment 7 Samuel Pitoiset 2017-09-21 14:50:39 UTC
A temporary workaround is to use R600_DEBUG="nodccfb".
Comment 8 Thomas J. Moore 2017-11-03 00:54:43 UTC
(In reply to Samuel Pitoiset from comment #7)
> A temporary workaround is to use R600_DEBUG="nodccfb".

Does the existence of this workaround mean you do not intend to fix the bug?  Given that there have been 2 17.2 releases (and 17.3 is in rc2) since this was written, and the bug is still present, I guess so.  Gentoo is making it really hard to retain my own workaround (don't upgrade to 17.2) due to its dependency on llvm-4, so I guess I'll just have to live with your workaround.
Comment 9 Samuel Pitoiset 2017-11-03 08:04:57 UTC
No, the bug should be fixed. I just didn't have much time to work on it to be honest.
Comment 10 Thomas J. Moore 2017-11-03 15:30:14 UTC
(In reply to Samuel Pitoiset from comment #9)
> No, the bug should be fixed. I just didn't have much time to work on it to
> be honest.

OK, no hurry.  It's not like it's corrupting memory or anything, and the workaround does work.  I was just concerned it would never be fixed.
Comment 11 Timothy Arceri 2018-04-03 07:11:37 UTC
(In reply to Thomas J. Moore from comment #5)
> I'm not sure I trust dropbox entirely (it's a bit invasive), but I went
> ahead and created an account to upload the trace file:
> 
> https://www.dropbox.com/s/uo6kllmpr1b5jrt/satinav.trace?dl=0
> 
> This is from Chains of Satinav.  The sparkle grid appears in the large
> cursor in the middle of the screen when it's hovering over the ship's
> window.  Normally it is grayish with a wave pattern over it, but when
> broken, it's just a sparkle grid.  Please let me know if/when you're
> downloaded it, so I know it worked, and I can delete it.
> 
> Note that I got a trace from KOTOR as well, but it is not usably replayable,
> unlike this one.

Deleting the trace means no one else can investigate the bug. Is this still a problem?
Comment 12 Timothy Arceri 2018-04-03 08:34:13 UTC
Possibly a duplicate of bug 105152
Comment 13 Thomas J. Moore 2018-04-03 15:43:45 UTC
(In reply to Timothy Arceri from comment #11)
> Deleting the trace means no one else can investigate the bug. Is this still
> a problem?

I assumed Samuel Pitoiset already figured out what the problem was, particularly since the git bisect pointed to a change he made.  Perhaps you can contact him directly?  It's been six months, and multiple releases of Mesa, so I pretty much don't believe this bug will get looked at, and don't care if it gets fixed or not.  Testing if it's still broken is already more trouble for me than it's worth.  I don't trust dropbox, and have no intention of uploading this file again.

(In reply to Timothy Arceri from comment #12)
> Possibly a duplicate of bug 105152

Feel free to mark it as such, so I don't have to deal with it any more.  It's not the first bug of mine that's been marked as a duplicate of a later bug report.  (I didn't read it, but again, I don't care any more).  If it's not really a duplicate, feel free to just close this as "won't fix".
Comment 14 Timothy Arceri 2018-09-08 06:33:03 UTC

*** This bug has been marked as a duplicate of bug 105152 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.