Bug 105152 - Display artifacts related to DCC on radeonsi
Summary: Display artifacts related to DCC on radeonsi
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
: 102885 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-18 14:30 UTC by Mario Kleiner
Modified: 2018-09-08 16:09 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
apitrace exposing the problem in realtime replay (8.32 MB, application/octet-stream)
2018-02-18 14:30 UTC, Mario Kleiner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mario Kleiner 2018-02-18 14:30:42 UTC
Created attachment 137424 [details]
apitrace exposing the problem in realtime replay

This i observe on radeonsi with a Volcanic Islands R9 380 TONGA with one specific demo in my toolkit.

What the demo does is it renders between 1 and 5 textured quads on top of each other, each quad with the same texture, but different texture coordinates and "zoom". It uses alpha-blending with GL_SRC_ALPHA, GL_ONE_MINUS_SRC_ALPHA to blend the layers together. All in an endless animation that creates an interesting "infinite zoom" effect.

Attached an apitrace of a few seconds of execution of the animation loop.

If the demo doesn't draw about more than 3 such quads per animation frame on top of each other, the animation looks correct. With 5 quads i get some weird dynamic noise in some parts of the displayed content, as if parts of the pixels would somehow overflow and wrap around.

If one steps through the apitrace, looking up state at swapbuffers, each rendered frame looks correct, but if one replays the trace in real-time, the visual artifacts show up, so it doesn't seem to be a rendering problem, but some kind of interaction with DCC?

If i set R600_DEBUG=nodccfb then all artifacts disappear.
Running on older Evergreen hw under r600 instead of radeonsi doesn't cause these artifacts.

The problem was already present in some earlier Mesa version (17.2 as shipping in Ubuntu 17.10), and is present in master.

Another way to reproduce is running the demo on a Debian/Ubuntu system via:

1. apt install octave-psychtoolbox-3
2. octave --eval ShepardZoomDemo

Source code of the demo under:

https://github.com/Psychtoolbox-3/Psychtoolbox-3/blob/master/Psychtoolbox/PsychDemos/OpenGL4MatlabDemos/ShepardZoomDemo.m
Comment 1 Timothy Arceri 2018-09-08 06:32:49 UTC
This appears to have been fixed at some point. Running on Mesa from git I no longer see the artifacts.

Marking as fixed. Feel free to reopen if you still have issues with a current version of Mesa.
Comment 2 Timothy Arceri 2018-09-08 06:33:03 UTC
*** Bug 102885 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.