Bug 102931 - [945GSE] display corruption boot
Summary: [945GSE] display corruption boot
Status: CLOSED DUPLICATE of bug 102929
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium major
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
: 103223 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-09-21 19:59 UTC by Jan Vesely
Modified: 2018-01-04 20:05 UTC (History)
4 users (show)

See Also:
i915 platform: I945GM
i915 features: display/Other


Attachments
dmesg 4.13.3 (74.70 KB, text/plain)
2017-09-21 19:59 UTC, Jan Vesely
no flags Details
dmesg drm.debug=14 (59.23 KB, text/plain)
2017-09-27 15:21 UTC, Jan Vesely
no flags Details
corrupted gdm screen (2.38 MB, image/jpeg)
2017-09-27 16:22 UTC, Jan Vesely
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Vesely 2017-09-21 19:59:14 UTC
Created attachment 134416 [details]
dmesg 4.13.3

kernel 4.13.3
plymouth start corrupted and the corruption stays in both gdm(wayland) and vt consoles

the systems works OK (other than warning in #101937) when it boots linux 4.12.14
Comment 1 Jani Nikula 2017-09-25 17:49:54 UTC
Please boot with drm.debug=14 module parameter when adding dmesg.

Please take a picture, hard to assess what the corruption looks like.

If you can, please bisect.
Comment 2 Jan Vesely 2017-09-27 15:21:41 UTC
Created attachment 134507 [details]
dmesg drm.debug=14
Comment 3 Jan Vesely 2017-09-27 16:22:12 UTC
Created attachment 134509 [details]
corrupted gdm screen
Comment 4 Jan Vesely 2017-09-27 16:23:29 UTC
captured screenshots are not corrupted, just the display.
Comment 5 Rob Irvin 2017-10-09 19:12:54 UTC
I am also experiencing this issue with Archlinux 4.13.3, 4.13.4 and 4.13.5 running LightDM.  Corruption happens on the console during boot and remains during LightDM and when logging in to XFCE.

Like you mentioned, on 4.12.x I also received the drm_atomic_helper_update_legacy_modeset_state calltrace but display worked OK.  I now receive this error and the following:

[    7.829242] plane B assertion failure, should be off on pipe B but is still active
[    7.829292] ------------[ cut here ]------------
[    7.829480] WARNING: CPU: 0 PID: 215 at drivers/gpu/drm/i915/intel_display.c:1252 assert_planes_disabled+0x128/0x140 [i915]

A quick search has bought up this bug report as well as the following from 4.3 which produces the same corruption and warning message:

https://bugs.freedesktop.org/show_bug.cgi?id=92655
Comment 6 Serhiy Zahoriya 2017-10-23 00:42:26 UTC
Also experiencing this after upgrade, the same "plane B assertion failure, should be off on pipe B but is still active".

Adding i915.modeset=0 does not corrupt the screen but also sets the lowest resolution.
Comment 7 Serhiy Zahoriya 2017-10-23 00:46:02 UTC
*** Bug 103223 has been marked as a duplicate of this bug. ***
Comment 8 Serhiy Zahoriya 2017-10-23 09:13:30 UTC
There is a comment at
https://bugzilla.redhat.com/show_bug.cgi?id=1498725
that commits at
https://github.com/vsyrjala/linux/commits/plane_sanitation_2_v4.13
should solve the issue.
Comment 9 Ville Syrjala 2017-12-07 18:00:35 UTC

*** This bug has been marked as a duplicate of bug 102929 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.