Bug 103268 - [llvmpipe] piglit texdepth regression
Summary: [llvmpipe] piglit texdepth regression
Status: RESOLVED DUPLICATE of bug 103265
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords: bisected, regression
Depends on: 103350
Blocks:
  Show dependency treegraph
 
Reported: 2017-10-13 22:18 UTC by Vinson Lee
Modified: 2017-10-18 19:15 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2017-10-13 22:18:51 UTC
mesa: 77d3d71f23b32550b045b5f74b7a5e6ca54d83c5 (master 17.3.0-devel)

$ ./bin/texdepth -auto
GL_ARB_shadow_ambient not supported.
Illegal sampler view creation without bind flag
Probe color at (80,16)
  Expected: 0.000000 0.000000 0.000000 1.000000
  Observed: 1.000000 1.000000 1.000000 1.000000
Test failed: 'EXT_shadow_func: GL_LESS'
See above for details.

PIGLIT: {"result": "fail" }


be3ab867bd444594f9d9e0f8e59d305d15769afd is the first bad commit
commit be3ab867bd444594f9d9e0f8e59d305d15769afd
Author: Marek Olšák <marek.olsak@amd.com>
Date:   Mon Oct 2 22:30:55 2017 +0200

    tgsi: implement tgsi_util_get_inst_usage_mask properly
    
    All opcodes are handled.
    
    Reviewed-by: Nicolai Hähnle <nicolai.haehnle@amd.com>

:040000 040000 d1db49cee47cbe6ea3ac52d46bbf4a612f14d3be 11c3d50751b4c921bec7cf463e8c52d4162af19e M	src
bisect run success
Comment 1 Roland Scheidegger 2017-10-18 19:15:37 UTC

*** This bug has been marked as a duplicate of bug 103265 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.