Bug 103350 - llvmpipe regressions due to be3ab867
Summary: llvmpipe regressions due to be3ab867
Status: RESOLVED DUPLICATE of bug 103265
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 103265 103266 103268
  Show dependency treegraph
 
Reported: 2017-10-18 19:10 UTC by Tim Rowley
Modified: 2017-10-18 19:15 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Rowley 2017-10-18 19:10:16 UTC
This commit causes six regressions for llvmpipe, which remain broken in mesa-master.

commit be3ab867bd444594f9d9e0f8e59d305d15769afd
Author: Marek Olšák <marek.olsak@amd.com>
Date:   Mon Oct 2 22:30:55 2017 +0200

    tgsi: implement tgsi_util_get_inst_usage_mask properly
    
    All opcodes are handled.
    
    Reviewed-by: Nicolai Hähnle <nicolai.haehnle@amd.com>

Regressed piglit tests:

depth-tex-compare
sampler-cube-shadow
texdepth
tex-ahadow1d
txp-shadow2d
txp-shadow2drect
Comment 1 Roland Scheidegger 2017-10-18 19:15:08 UTC
There's already 3 bugs for this, we don't need a fourth.

*** This bug has been marked as a duplicate of bug 103265 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.