Bug 103631 - Screen corrupted when using three 4K monitors with USB-C dock
Summary: Screen corrupted when using three 4K monitors with USB-C dock
Status: CLOSED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-08 23:18 UTC by Marat Bakeev
Modified: 2018-05-04 12:11 UTC (History)
2 users (show)

See Also:
i915 platform: KBL
i915 features: display/atomic


Attachments
screen corruption example (174.38 KB, image/jpeg)
2017-11-08 23:18 UTC, Marat Bakeev
no flags Details
dmesg debug on display config attemp (70.81 KB, text/plain)
2017-11-08 23:20 UTC, Marat Bakeev
no flags Details
full dmesg from boot (1.02 MB, text/plain)
2017-11-08 23:21 UTC, Marat Bakeev
no flags Details
xrandr output (2.17 KB, text/plain)
2017-11-08 23:26 UTC, Marat Bakeev
no flags Details
dmesg debug full log on a 4.14rc8 kernel from git (23.36 KB, text/x-log)
2017-11-10 02:22 UTC, Marat Bakeev
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marat Bakeev 2017-11-08 23:18:43 UTC
Created attachment 135329 [details]
screen corruption example

Hi all.

I've got a Dell XPS 15 9560 running Archlinux with kernel  4.13.11.
I'm using Cinnamon desktop 3.4.6, xorg-server 1.19.5.
The laptop has Nvidia GeForce GTX 1050 (4GB GDDR5); Intel HD Graphics 630.
The intel card is set up with KMS, I don't have xf86-video-intel installed.

I'm trying to use a Dell TB16 dock with two LG 27UD58-B 27" UHD 4K monitors and a built-in screen. Screens are connected through displayport cables to the TB16 dock.
(Intel(R) Core(TM) i7-7700HQ)

Screens work fine in mirror mode, but as soon as I set the displays to be horizontally aligned next to eachother, screen corrupts. It works fine if one of the screens is positioned below the other two.
Comment 1 Marat Bakeev 2017-11-08 23:20:32 UTC
Created attachment 135330 [details]
dmesg debug on display config attemp

This is dmesg log of what happens when I align all three monitors horizontally in 'display settings' and press apply. After the timeout, the screens revert to their previous setup
Comment 2 Marat Bakeev 2017-11-08 23:21:51 UTC
Created attachment 135331 [details]
full dmesg from boot
Comment 3 Marat Bakeev 2017-11-08 23:26:27 UTC
I've tried patching the i915 module with this patch, but it didn't seem to help.

https://www.reddit.com/r/linux/comments/6bghzm/increasing_maximum_xorg_virtual_screen_resolution/dhn75qy/
Comment 4 Marat Bakeev 2017-11-08 23:26:44 UTC
Created attachment 135332 [details]
xrandr output
Comment 5 Marat Bakeev 2017-11-08 23:36:14 UTC
The same setup works fine in Windows 10.
Comment 6 Elizabeth 2017-11-09 20:04:26 UTC
Not sure if relevant. From dmesg:

[drm:intel_dump_pipe_config [i915]] planes on this crtc
[drm:intel_dump_pipe_config [i915]] [PLANE:40:plane 1C] disabled, scaler_id = -1
[drm:intel_dump_pipe_config [i915]] [PLANE:42:plane 2C] disabled, scaler_id = -1
[drm:intel_dump_pipe_config [i915]] [PLANE:44:cursor C] disabled, scaler_id = -1
...
[drm:intel_prepare_plane_fb [i915]] failed to pin object
Comment 7 Marat Bakeev 2017-11-10 02:21:59 UTC
Just tried my setup with the kernel compiled from git - linux-git 4.14rc8.r13.g87df26175e67-1,
it hangs moments after I log into the system and the system sets monitors mode, so I can't test if the monitors work when aligned horizontally.

I'm attaching a dmesg from that.
Comment 8 Marat Bakeev 2017-11-10 02:22:28 UTC
Created attachment 135368 [details]
dmesg debug full log on a 4.14rc8 kernel from git
Comment 9 Marat Bakeev 2017-11-21 23:41:10 UTC
Is there anything else needed from me for this bug?

This issue is very annoying, I'm ready to test any patches to try to fix this
Comment 10 Jani Saarinen 2018-03-29 07:11:04 UTC
First of all. Sorry about spam.
This is mass update for our bugs. 

Sorry if you feel this annoying but with this trying to understand if bug still valid or not.
If bug investigation still in progress, please ignore this and I apologize!

If you think this is not anymore valid, please comment to the bug that can be closed.
If you haven't tested with our latest pre-upstream tree(drm-tip), can you do that also to see if issue is valid there still and if you cannot see issue there, please comment to the bug.
Comment 11 Inad 2018-04-10 07:36:15 UTC
Same problem on an Intel (R) Core (TM) i7-6700HQ
with 3 4K screens. When a window exceeds 8064 px it corrupts
DP1 + HDMI1 + HDMI2
Comment 12 Inad 2018-04-20 08:22:29 UTC
My problem I have identified and it is a problem of "Mesa"
But the effect on the image is the same

* https://bugs.freedesktop.org/show_bug.cgi?id=106145
* https://bugs.freedesktop.org/show_bug.cgi?id=106144
Comment 13 Jani Saarinen 2018-04-25 10:14:54 UTC
Can you also see if this bug: https://bugs.freedesktop.org/show_bug.cgi?id=104425 solves your issues and test with latest drm-tip: https://cgit.freedesktop.org/drm-tip?
Comment 14 Jani Saarinen 2018-05-04 12:10:57 UTC
Closing, please re-open if occurs again.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.